1 Reply Latest reply on Oct 6, 2004 12:48 PM by Raj Kumar

    Having problem connecting apache-2.0.49 with jboss3.2.5

    Raj Kumar Newbie

      These are the steps, I followed

      1. Downloaded mod_jk-1.2.6.so

      2. Modified httpd.conf
      # JBoss Configuration
      # Include mod_jk configuration file
      Include conf/mod-jk.conf

      3. Created mod-jk.conf with following lines

      #Load mod_jk module
      # Specify the filename of the mod_jk lib
      LoadModule jk_module modules/mod_jk-1.2.6.so

      # Where to find workers.properties
      JkWorkersFile conf/workers.properties

      # Where to put jk logs
      JkLogFile logs/mod_jk.log

      # Set the jk log level [debug/error/info]
      JkLogLevel info

      # Select the log format
      JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"

      # JkOptions indicates to send SSK KEY SIZE
      #JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories

      # JkRequestLogFormat
      JkRequestLogFormat "%w %V %T"

      JkMount /servlet/* loadbalancer


      4. created workers.properties file
      # Define Node1
      worker.node1.port=8080
      worker.node1.host=mymachine
      worker.node1.type=ajp13
      worker.node1.lbfactor=1
      worker.node1.local_worker=1
      worker.node1.cachesize=10

      # Define Node2
      #worker.node2.port=8009
      #worker.node2.host= node2.mydomain.com
      #worker.node2.type=ajp13
      #worker.node2.lbfactor=1
      #worker.node2.local_worker=1
      #worker.node2.cachesize=10

      # Load-balancing behaviour
      worker.loadbalancer.type=lb
      #worker.loadbalancer.balanced_workers=node1, node2
      worker.loadbalancer.balanced_workers=node1
      worker.loadbalancer.sticky_session=1
      worker.loadbalancer.local_worker_only=1
      worker.list=loadbalancer


      5. Added attribute jvmRoute in server.xml for my server


      6. Restarted Jboss & Apache

      I can access the servlet directly from Jboss but not through apache

      http://servername:8080/servlet/Hello works fine.
      http://servername:80/servlet/Hello does not work...

      Did I miss any step?

      Raj