1 Reply Latest reply on Oct 16, 2004 11:29 AM by Bruno Beloff

    security-domain and JBoss 3.2.6

    Bruno Beloff Newbie

      Hi.

      I've got a problem moving from JBoss 3.2.5 to 3.2.6. It seems like my security-domain isn't being recognised. The security-domain is specified in the jboss-web.xml of a number of deployed applications as:

      <security-domain>java:/jaas/ClassCalendar</security-domain>
      


      The corresponding entry in login-config.xml is:

      <application-policy name="ClassCalendar">
       <authentication>
       <login-module code="org.jboss.security.auth.spi.DatabaseServerLoginModule" flag="required">
       <module-option name="dsJndiName">java:/DefaultDS</module-option>
       <module-option name="principalsQuery"> SELECT password FROM cc_v012_authentications WHERE userName=? </module-option>
       <module-option name="rolesQuery"> SELECT role, 'Roles' FROM cc_v012_authentications WHERE userName=? </module-option>
       </login-module>
       </authentication>
       </application-policy>
      


      when authentication takes place, I get the exception:

      ERROR [UsersRolesLoginModule] Failed to load users/passwords/role files
      java.io.IOException: Properties file roles.properties not found
      ...
      


      The only work-around I have for this is to remove the "other" application-policy in login-config.xml, and rename my own application-policy "other" in its place. So it looks like my application-policy is ignored unless it carries the default name.

      What's the fix here? Am I missing some configuration element? This arrangement worked fine in JBoss 3.2.5.

      Thank you very much for your help

      Bruno.