1 Reply Latest reply on Oct 29, 2004 5:26 AM by Darran Lofthouse

    JBoss 4.0 Classloading Problems

    dheerajchugh Newbie

      Hi,

      I took the JBoss 4.0 version and tried to port my applications which were running fine on JBoss 3.2.5, where i had my applications running in the default server mode. But when i copied the same applications on JBoss 4.0, it started giving me problems with Log4J, which did not worked for me, kind of throwing Does not implement Log kind of errors. Then going through one of the forums i found that if i have to get the same kind of classloading which is there in JBoss 3.2.x then i will have to use the standard configuration, so then i copied the application in standard server configuration, after that Log4J problem went away but now i am gettting unable to compile JSP errors, which is very weird, even in my jboss-service.xml fild under jbossweb-tomcat50.sar\META-INF directory, i have the "UseJBossWebLoader" value set to false, even after that i am facing this issue.

      May be i am doing something wrong, but the strange thing to me is that, the same applications are running fine on 3.2.4 and 3.2.5

      Has anyone tried his hands on JBoss 4.0 and has anyone come across such issues on JBoss.

      Looking forward to some luck.


      Regards,
      Dheeraj.