0 Replies Latest reply on Nov 3, 2004 3:25 PM by Don Hill

    jboss-4.0.0 and class-loader

    Don Hill Newbie

      I am trying to get a war deployed to the default server, i alreayd know that I can use the standard but I will later be moving to the all server for clustering. I am having a conflict issue between the version of castor we use and the version in jboss-4.0.0/server/default/lib, I have set this in my jboss-web.xml and the server still seems to pick up the one loaded in the server/lib folder, here is my class-loader config
      <class-loading java2ClassLoadingCompliance='false'>
      <loader-repository>
      dot.com:war=jboss4.war
      <loader-repository-config>java2ParentDelegation=true</loader-repository-config>
      </loader-repository>
      </class-loading>

      I have tryied other but they don't seem to work, always get the ClassCastException, if I remove the jar it works fine, I have also tried all the option that I can think of as far as the ClassLoading page http://www.jboss.org/wiki/Wiki.jsp?page=ClassLoadingConfiguration states.

      Any help in this would be greatfull

      .don