0 Replies Latest reply on Jun 20, 2007 3:05 AM by fhh

    Wrong dependencies in ajax4jsf tutorial?

    fhh Expert

      The wiki http://labs.jboss.com/wiki/UsingCDKStartUp states that the pom for the parent project of the cdk ought to look like this:

      <?xml version="1.0" encoding="UTF-8"?>
      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
      <modelVersion>4.0.0</modelVersion>
      <groupId>org.mycompany</groupId>
      <artifactId>mylib-parent</artifactId>
      <url>http://mycompany.org</url>
      <version>1.0-SNAPSHOT</version>
      <packaging>pom</packaging>
      <dependencies>
       <dependency>
       <groupId>javax.servlet</groupId>
       <artifactId>servlet-api</artifactId>
       <version>2.4</version>
       <scope>provided</scope>
       </dependency>
       <dependency>
       <groupId>javax.servlet</groupId>
       <artifactId>jsp-api</artifactId>
       <version>2.0</version>
       <scope>provided</scope>
       </dependency>
       </dependencies>
      </project>
      


      The dependencies seem completly wrong to me. To get my component to compile I replaced them by the following dependencies:

       <dependencies>
       <dependency>
       <groupId>javax.servlet</groupId>
       <artifactId>jsp-api</artifactId>
       <version>2.0</version>
       <scope>provided</scope>
       </dependency>
       <dependency>
       <groupId>org.ajax4jsf</groupId>
       <artifactId>ajax4jsf</artifactId>
       <version>1.1.2-SNAPSHOT</version>
       </dependency>
       <dependency>
       <groupId>junit</groupId>
       <artifactId>junit</artifactId>
       <version>3.8.1</version>
       <scope>test</scope>
       </dependency>
       </dependencies>
      


      ajax4jsf provides the base classes for component, jsp-api is needed for the jsp tag support and junit for the unit tests.

      If any of the developers will confirm this, I will change the wiki page.

      Regards

      Felix