1 Reply Latest reply on Nov 30, 2004 4:13 PM by pjrichter

    UnsupportedClassVersionError in jmx-console

    Michael Kopp Newbie

      Hi

      I get the following error all of a sudden when I try to open the jmx-console.

      java.lang.UnsupportedClassVersionError: org/apache/jsp/index_jsp (Unsupported major.minor version 49.0)
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
      at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
      at org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:156)
      at org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:69)
      at org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:548)
      at org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:136)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:307)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)


      Can anybody tell me please how this can happen? It worked before and I didn't change anything. I even binary compared the installation with to original download. nothing changed.

      Does anybody know which jar file this is anyway? and what I could do to solve it?

      Please help
      Mike