3 Replies Latest reply on Nov 30, 2004 3:43 PM by Scott Stark

    New classloader in 4.0?

    pergesu Newbie

      I installed 4.0 yesterday, and have been trying to get some apps to deploy on it. These are all apps that worked perfectly fine on 3.2.6...and now suddenly a bunch of NoClassDefFoundError exceptions are coming up. I've got the necessary classes in the ejb-jar, war file, ear file, everywhere, so it makes no sense that it can't find it. And like I said, I've deployed these without any problem on 3.2.6. I've spenty nearly 12 hours looking around, trying to figure something out, to no avail, and getting pretty frustrated. Anybody have any clue what might be going on?

        • 1. Re: New classloader in 4.0?
          Scott Stark Master

          From the 4.0.0 release notes:
          http://sourceforge.net/docman/display_doc.php?docid=24779&group_id=22866

          The 4.0.0 release ships with a different set of pre-configured server configuration file sets:

          default: The default configuration with all required j2ee 1.4 services. It also uses
          scoped deployments for ears with call by value semantics for ejb calls, and jndi lookups. Note that this can cause migration difficulties when porting from a 3.2.x release which was not using scoped class loading. Try the standard configuration if you see class loading issues during migration.

          standard: The configuration consistent with the legacy 3.2.x 'default' configuration
          that uses unscoped deployments and call by reference semantics for same VM ejb calls
          and jndi lookups.

          minimal: A minimal configuration with hot deployment of services, and a logging and jndi
          naming service.

          all: The all inclusive configuration of the services avaliable in jboss.


          We are reverting back to the 3.2.x default configuration file sets for the 4.0.1 release since this has caused so many issues.

          • 2. Re: New classloader in 4.0?
            pergesu Newbie

            Thanks for the quick reply...but I tried it with the standard config instead of default, and there was no difference. Same problems in all my apps. It also seems that I can't set the jndi-name of any bean. JBoss just gives it either BeanName if it's a remote EJB, or local/BeanName if it's a local bean. This makes it impossible to reference them any other way, which is obviously no good. Any ideas on what to do?

            • 3. Re: New classloader in 4.0?
              Scott Stark Master

              Then I don't know why there should be an issue. You'll have to create a bug report with a sample app that fails to deploy between 3.2.6 and 4.0.0.

              http://jira.jboss.com/jira/browse/JBAS