1 Reply Latest reply on Nov 30, 2004 4:49 PM by Lucy Yang

    jboss not starting or with error

    Jonas Bernoulli Newbie

      i just reasently installed jboss 4.0 and was able to start it from the eclipse plugin myeclipse.

      there was this error though:

      20:58:11,214 WARN [ServiceController] Problem starting service jboss.mq:service=InvocationLayer,type=HTTP
      java.lang.NoClassDefFoundError: com/sun/net/ssl/HostnameVerifier
       at java.lang.Class.forName1(Native Method)
       at java.lang.Class.forName(Class.java:180)
       at org.jboss.mq.il.http.HTTPServerIL.class$(HTTPServerIL.java:43)
       at org.jboss.mq.il.http.HTTPServerIL.<clinit>(HTTPServerIL.java:43)
       at org.jboss.mq.il.http.HTTPServerILService.startService(HTTPServerILService.java:69)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:271)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:221)
       at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:62)
       at java.lang.reflect.Method.invoke(Method.java:391)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:141)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:80)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:72)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:230)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:642)
       at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:844)
       at $Proxy29.start(Unknown Source)
       at org.jboss.system.ServiceController.start(ServiceController.java:369)
       at org.jboss.system.ServiceController.start(ServiceController.java:391)
       at org.jboss.system.ServiceController.start(ServiceControll ....


      i didn't notice until later that i can start it from the commandline at all:

      ~ root# /opt/jboss-4.0.0RC1/bin/run.sh
      =========================================================================
      
       JBoss Bootstrap Environment
      
       JBOSS_HOME: /usr/share/jboss
      
       JAVA: /opt/ibm-jdk-bin-1.4.2/bin/java
      
       JAVA_OPTS: -server -Xms128m -Xmx128m -Dprogram.name=run.sh
      
       CLASSPATH: /usr/share/jboss/bin/run.jar:/opt/ibm-jdk-bin-1.4.2/lib/tools.jar
      
      =========================================================================
      
      The JVM option is invalid: -server
      Could not create the Java virtual machine.
      ....
      


      i have tried installing jboss as root and as user, with same result.


      i am rather lost here any suggestions what might be going wrong?

        • 1. Re: jboss not starting or with error
          Lucy Yang Newbie

          This is because you have IBM's JDK and "-server" option is Sun's Java Hotspot JVM's option and not supported by IBM's JVM. When running from the command line, try modifying the run.sh to remove the "-server" option. The other options shown from your echoed message are general and are supported by IBM's JVM also.

          Which platform did you run eclipse on? Your comman line shows like some UNIX or Linux. The error you got when starting from Eclipse showed those Sun classes are missing. If this is also on your unix/linux platform, you may have to get Sun's JDK or/and some proper jars from Sun. I run Eclipse on Windows with Sun's JDK and never used jboss plugin, so don't know what you may need for that plugin on unix/linux. Don't even know if it supports IBM's JVM.