5 Replies Latest reply on Dec 8, 2004 1:34 PM by Christopher Smith

    4.0.0 installing an an AS400

    Christopher Smith Newbie

      I have installed on an AS400. I set the environment variable
      JAVA_HOME = /QIBM/ProdData/Java400/jdk14

      Java reports -server is not a valid arguement.

      when I execute run.sh, I get:

      run.sh
      ulimit: 001-0007 Variable unlimited is not set.
      run.sh: Could not set maximum file descriptor limit: unlimited
      =========================================================================
      
       JBoss Bootstrap Environment
      
       JBOSS_HOME: /JBOSS/jboss-4.0.0
      
       JAVA: /QIBM/ProdData/Java400/jdk14/bin/java
      
       JAVA_OPTS: -server -Xms128m -Xmx128m -Dprogram.name=run.sh
      
       CLASSPATH: /JBOSS/jboss-4.0.0/bin/run.jar:/QIBM/ProdData/Java400/jdk14/lib/tools.jar
      
      =========================================================================
      
      -server: argument not valid
      Usage: java [-options] class [args...]
       (to execute a class)
       or java -jar [-options] jarfile [args...]
       (to execute a jar file)
      where options include:
       -cp -classpath <directories and zip/jar files separated by colons>
       set search path for application classes and resources
       -D<name>=<value>
       set a system property
       -verbose[:class|gc|jni]
       enable verbose output
       -version print product version and exit
       -showversion print product version and continue
       -? -help print this help message
       -X print help on non-standard options


      Any suggestions?

        • 1. Re: 4.0.0 installing an an AS400
          Franco Apprentice

          The -server parameter is not supported on the IBM JVM,
          it is only hotspot.
          Remove the parameter.
          Ciao.

          • 2. Re: 4.0.0 installing an an AS400
            Christopher Smith Newbie

            That is what I thought but for the life of me I could not figure out where in run.sh that it was being set. I finally figured out that I hade to change run.conf

            I changed JAVA_OPTS and JAVA_HOME in run.conf and I did not have to change any environment variables.

            Thank you

            • 3. Re: 4.0.0 installing an an AS400
              Christopher Smith Newbie

              I can execute run.sh. The server appears to start. You can get a page when you point your browser at http://ouras400:8080

              The Log shows:

              2004-12-06 22:01:34,074 INFO [org.apache.jk.server.JkMain] Jk running ID=0 time=0/1885 config=null
              2004-12-06 22:01:37,365 INFO [org.jboss.system.server.Server] JBoss (MX MicroKernel) [4.0.0 (build: CVSTag=JBoss_4_0_0 date=200409200418)] Started in 1m:35s:700ms
              



              There are some excecptions during startup.

              2004-12-06 22:00:41,503 DEBUG [tomcat.localhost./ebxmlrr.Context] Starting tomcat.localhost./ebxmlrr.Context
              2004-12-06 22:00:41,508 DEBUG [tomcat.localhost./ebxmlrr.Context] Configuring default Resources
              2004-12-06 22:00:43,126 DEBUG [tomcat.localhost./ebxmlrr.Context] Configuring non-privileged default Loader
              2004-12-06 22:00:44,885 ERROR [org.apache.catalina.util.ExtensionValidator] Failure loading extension /QIBM/ProdData/Java400/jdk14/lib/ext/eimos400.jar
              java.io.FileNotFoundException: No such path or directory. /QIBM/ProdData/Java400/jdk14/lib/ext/eimos400.jar


              2004-12-06 22:01:12,521 DEBUG [org.jboss.jdbc.HypersonicDatabase] Starting jboss:database=localDB,service=Hypersonic
              2004-12-06 22:01:14,075 ERROR [org.jboss.jdbc.HypersonicDatabase] Starting failed jboss:database=localDB,service=Hypersonic
              java.sql.SQLException: User not found: SA


              and

              2004-12-06 22:01:14,081 WARN [org.jboss.system.ServiceController] Problem starting service jboss:database=localDB,service=Hypersonic
              java.sql.SQLException: User not found: SA



              For the first execption, I have verified that the named jar file does exist. I do not know anything about Hypersonic other that it is supposed to be embeded in JBOSS and run anywhere. I do not know what the cause of the problem.

              When you select the JMX Console Link, jou get a page

              HTTP Status 500 -
              
              type Exception report
              
              message
              
              description The server encountered an internal error () that prevented it from fulfilling this request.
              
              exception
              
              org.apache.jasper.JasperException: Unable to compile class for JSP


              • 4. Re: 4.0.0 installing an an AS400
                Christopher Smith Newbie

                Sorry, I hit the submit button.

                I unerstand that a default config should run. I have googled and searched this site for any AS400 specific information but I could not find any.

                Any hints are appreicated

                cjs

                • 5. Re: 4.0.0 installing an an AS400
                  Christopher Smith Newbie

                  Status

                  I have determined that the error not being able to load eimos400.jar was valid. There was a symbolic link in the directory but no file where the link was pointed. Under V5R2 of os400, it is not loaded by default. I had to load a PTF.

                  I still got the error about SA not being a valid user.

                  After applying the PTF, JBOSS 3.2.6 installs and runs without modification or error.