3 Replies Latest reply on Dec 5, 2005 5:56 PM by ?ukasz

    Problem installing JBOSS

    Ronald Suyom Newbie

      Hi,

      I've installed JBOSS on my W2K Server and did the installation in c:\program files\jboss-4.0.1. But since I have an issue with the space with the directory structure, I decided to uninstall it. But for some reason, it won't get uninstalled so I manually removed the files from the directory and remove the application from the add/remove program. When I tried to install it on c:\jboss-4.0.1 or to any directory, it won't install and I've encountered an error description below.

      (Dec 8, 2004 10:11:25 AM), Install, com.installshield.product.service.product.PureJavaProductServiceImpl$Installer, err, java.lang.NullPointerException
      STACK_TRACE: 25
      java.lang.NullPointerException
      at java.util.Hashtable.containsKey(Unknown Source)
      at com.installshield.product.service.registry.LoggedSoftwareObject.addRequired(Unknown Source)
      at com.installshield.product.service.registry.LoggedSoftwareObject.setRequired(Unknown Source)
      at com.installshield.product.service.registry.VPDDef.loadSoftwareObject(Unknown Source)
      at com.installshield.product.service.registry.VPDDef.getSoftwareObject(Unknown Source)
      at com.installshield.product.service.registry.PureJavaRegistryServiceImpl.findSoftwareObject(Unknown Source)
      at com.installshield.product.service.registry.PureJavaRegistryServiceImpl.findSoftwareObjects(Unknown Source)
      at com.installshield.product.service.registry.PureJavaRegistryServiceImpl.getSoftwareObject(Unknown Source)
      at sun.reflect.GeneratedMethodAccessor102.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at com.installshield.wizard.service.LocalImplementorProxy.invoke(Unknown Source)
      at com.installshield.wizard.service.AbstractService.invokeImpl(Unknown Source)
      at com.installshield.product.service.registry.GenericRegistryService.getSoftwareObject(Unknown Source)
      at com.installshield.product.service.product.InstallableObjectVisitor.visitSoftwareObject(Unknown Source)
      at com.installshield.product.service.product.RequiredResourceIndices.visitSoftwareObject(Unknown Source)
      at com.installshield.product.service.product.InstallableObjectVisitor.visitProductBean(Unknown Source)
      at com.installshield.product.service.product.InstallableObjectVisitor.visitProductBeans(Unknown Source)
      at com.installshield.product.service.product.RequiredResourceIndices.getRequiredResourceIndices(Unknown Source)
      at com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.install(Unknown Source)
      at com.installshield.product.service.product.PureJavaProductServiceImpl$Installer.execute(Unknown Source)
      at com.installshield.wizard.service.AsynchronousOperation.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)


      Does anyone encountered this problem? Any suggestions?

      Thanks

        • 1. Re: Problem installing JBOSS
          Keith Farmer Newbie

          Same here. Eventually uninstalled Java and JBoss, reinstalled Java, pulled the non-installer based distribution of 4.0.0, and ran it that way. Now I'm getting the following whenever I try to browse an aop node in web-console:

          org.apache.jasper.JasperException: Unable to compile class for JSP
          
          Generated servlet error:
          C:\jboss-4.0.0RC1\server\default\work\jboss.web\localhost\web-console\org\apache\jsp\AOPBinding_jsp.java:9: cannot resolve symbol
          symbol : class IntroductionPointcut
          location: package pointcut
          import org.jboss.aop.pointcut.IntroductionPointcut;
           ^
          1 error
          
          
          
           org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:84)
           org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:332)
           org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:412)
           org.apache.jasper.compiler.Compiler.compile(Compiler.java:472)
           org.apache.jasper.compiler.Compiler.compile(Compiler.java:451)
           org.apache.jasper.compiler.Compiler.compile(Compiler.java:439)
           org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:511)
           org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:295)
           org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
           org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
           javax.servlet.http.HttpServlet.service(HttpServlet.java:810)


          • 2. Re: Problem installing JBOSS
            Mirko Tikalsky Newbie

            Hi Rasuyom,
            I've got the same problem. Did you manage to solve the problem?
            Maybe you can give me some advice?

            Thanx in advance
            Mirko

            • 3. Re: Problem installing JBOSS
              ?ukasz Newbie

              Hi

              I've got the same problem like Rasuyom, Mirko.Tikalsky.

              1. win2k SP4
              2. java version "1.5.0_02"
              Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_
              Java HotSpot(TM) Client VM (build 1.5.0_02-b09, mixed mode)
              and JAVA_HOME =.../jdk
              3. jboss-4.0.3SP1-installer.jar
              4. java -jar jboss-4.0.3SP1-installer.jar
              and
              - Error -
              java.lang.NullPointerException
              java.lang.NullPointerException
              at java.io.ObjectInputStream$PeekInputStream.read(ObjectInputStream.java
              :2217)
              at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream
              .java:2230)
              at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputS
              tream.java:2698)
              at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:750
              )
              at java.io.ObjectInputStream.(ObjectInputStream.java:268)
              at com.izforge.izpack.installer.InstallerBase.loadInstallData(InstallerB
              ase.java:89)
              at com.izforge.izpack.installer.GUIInstaller.(GUIInstaller.java:10
              2)
              at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

              at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruct
              orAccessorImpl.java:39)
              at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingC
              onstructorAccessorImpl.java:27)
              at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
              at java.lang.Class.newInstance0(Class.java:350)
              at java.lang.Class.newInstance(Class.java:303)
              at com.izforge.izpack.installer.Installer.main(Installer.java:53)

              Any solution?