2 Replies Latest reply on Nov 13, 2007 5:45 PM by Rena Yamamoto

    ajax4jsf spring webflow tiles integration issue

    Giuseppe Cupido Newbie

      i found a problem using ajax4jsf with spring webflow and tiles.
      The problem seems to be when the jsp page is rendered through webflow and tiles any ajax request in that page like

      <a4j:support event="...." rerender="...."\>

      has a text/html response-type and not a text/xml resonse-type.
      The effect in this case is a full page reloading like a submit command.
      I observed this in ajax4jsf log:

      case webflow tiles:

      debug[8:28:00,984]: Response with content-type: text/html;charset=UTF-8
      debug[8:28:00,984]: Full response content:
      <html lang=...> .....
      ........................
      debug[8:28:01,000]: Header Ajax-Response not found, search in
      warn[8:28:01,000]: No ajax response header
      debug[8:28:01,015]: Header Location not found, search in


      case same page without webflow:

      debug[8:26:13,328]: Response with content-type: text/xml;charset=UTF-8
      debug[8:26:13,328]: Full response content: <?xml version="1.0"?>
      <html lang=" .....

      jar used: ajax4jsf-1.1.1 myfaces-1.1.5 tomahawk-1.1.6 spring-webflow-1.0.4 struts-tiles-1.3.5

      faces-config configuration:


      <navigation-handler>
      org.springframework.webflow.executor.jsf.FlowNavigationHandler
      </navigation-handler>
      <variable-resolver>
      org.springframework.webflow.executor.jsf.DelegatingFlowVariableResolver
      </variable-resolver>
      <view-handler>
      org.apache.myfaces.tomahawk.application.jsp.JspTilesViewHandlerImpl
      </view-handler>


      <phase-listener>
      org.springframework.webflow.executor.jsf.FlowPhaseListener
      </phase-listener>


      Any suggestion ????