1 Reply Latest reply on Jan 13, 2005 2:27 PM by Mathias Willburger

    Deployment problems

    Mathias Willburger Newbie

      i am using eclipse + myeclipse plugin for J2EE development. i have just a small application using struts & hibernate but really big deployment problems.

      at first I PROMISE i had this application already running without errors and i changed NOTHING, not even deleted a single blank line in the sourcecode. yesterday i have started the application without errors but today the following happens:
      every time i want to deploy my project jboss does some differnet things. the best case is, if everything works fine. but especially when i redeploy my code or even delete the war file and deploy it completely new this happens. i don't know what to do, my only hope is to find somebody who solved this problem. here the cases what happen exactly:

      CASE 1: JBoss says web.xml is missing even if the war file is fully deployed
      CASE2: JBoss prints a lot of error messages
      CASE 3: or the deployment works fine BUT if i want to start the application, JBoss says that the welcome action forward is missing even if there is the forward in the struts config file

      i dont want to place the full error.log here but at the following link you find all the messages:

      CLICK HERE FOR THE FULL ERROR MESSAGES: [URL]http://www.lagerfeuer.at/jbosserrors.txt[/URL]


      i hope someone can help me because its annoying developing applications when these messages occure everytime, even if the project is (in my opinion) 100% correct programmed, and worked already withot errors!!

      p.s. maybe it is a deployment problem on my system? i am running the following configuration:
      - windows XP SP2
      - myeclipse 3.8.3, eclipse 3.0.1
      - svn version control (but the errors also occur when the project order is not unter version control)
      - java sdk version is 1.4_06
      - jboss version is 4.0.1 (also 4.0.0 does the same)
      - jboss is running in its standard configuration, i changed nothing.
      - i use xammp to run the mysql server
      - everything runs on my local machine

      are there known other applications which could be in conflict with jboss? firewalls, antivirus?

      at the moment it works fine so i us the time as long as it works and hope someone can help me until the errors come up again.

        • 1. Re: Deployment problems
          Mathias Willburger Newbie

          it seems i have found the problem (with help of myeclipse.com forums):

          CASE 2 was the problem! the web.xml was there and also the struts.xml were correct. BUT (at the moment i think thats it) when i was disconnected from the internet the DTD files were not found. this caused that the qhole war file was not corredtly deployed.
          and these different messages occured on different times because sometimes i deployed my file when i was online and used it when i was offline (with my notebook) and sometimes i deployed it when i was offline and used id offline....

          i hope that was the whole thing,..... at the moment it works fine again (as i am connected when i am deploying) ;-)


          so this was no jboss problem but a deployment problem with my struts and hibernate xmls