0 Replies Latest reply on Jan 15, 2005 9:34 PM by guycole

    Fedora3 and HANamingService

    guycole Newbie

      Hello, all. If your using Fedora3 and JBoss 3.2.6 you might have noticed this problem when running the "all" configuration.

      18:13:39,873 INFO [HANamingService] Listening on /0.0.0.0:1100
      18:13:39,882 WARN [HANamingService] Failed to start AutomaticDiscovery
      java.net.SocketException: bad argument for IP_MULTICAST_IF: address not bound to any interface
      


      This solution has two parts.

      The first step is to enable multicast, which you can do by typing (as root):
      "route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0"

      You can verify multicast is enabled by typing "route" - you should see something like:
      [root@zorak ~]# route
      Kernel IP routing table
      Destination Gateway Genmask Flags Metric Ref Use Iface
      192.168.169.0 * 255.255.255.0 U 0 0 0 eth0
      169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
      224.0.0.0 * 240.0.0.0 U 0 0 0 eth0
      default morticia 0.0.0.0 UG 0 0 0 eth0
      


      The 224 net is your clue that multicast is flying.

      The second part is to define the host properly by supplying the IP when you invoke run such as:
      "./run.sh -c all --host=192.168.169.179"

      Now I get:
      18:31:13,325 INFO [HANamingService] Listening on /192.168.169.179:1100
      18:31:13,331 INFO [DetachedHANamingService$AutomaticDiscovery] Listening on /192.168.169.179:1102, group=230.0.0.4, HA-JNDI address=192.168.169.179:1100