1 Reply Latest reply on Jan 21, 2005 5:59 AM by Thomas Fruehbeck

    SNMP traps are not sent

    Thomas Fruehbeck Newbie

      I am working with JBoss 3.2.7RC1 on Linux, j2sdk1.4.2_05

      I tried to activate SNMP-traps. On my W2k box it's OK at the first try.

      On the QA and the production system (Linux) NO traps are sent.

      I found a SnmpTrapAppenderTest in the log4j package, which is able to read the log4j.xml file.
      I tweaked it a bit to test all variations of the config (a logger for my lasses,
      a logger for jboss classes) and started it from the command line.

      Everything worked as intended (SNMP-Traps, console log, file).

      But the (absolutely) same log4j.xml insists in NOT sending SNMP-traps in JBoss all server.

      Can anyone help me?

        • 1. Re: SNMP traps are not sent
          Thomas Fruehbeck Newbie


          Problem identified: UNIX bind permission exception

          The send port is a low port, and in this installation jboss is running
          as jboss user. Thats why the server has not access to low ports.

          Unfortunately there is no output in the logs about this fact.
          The Exception is just swallowed and thus hard to track down.

          Fix: use a high port as local send port (I used 8161 see Tomcat 8080 8-)

          Thomas