0 Replies Latest reply on Jan 19, 2005 3:42 PM by Blue Ogre

    Jboss-Tomcat 404 status

    Blue Ogre Newbie

      Hi!

      I am a new to Java/Jboss. I have a problem which I hope someone will take a moment to help me with.

      Problem Description:

      I have a configuration that uses

      Apache 2.0.45 with SSL
      Jk2
      Jboss 3.2.1-Tomcat-4.1.24
      Struts 1.1

      Now this site does not have a problem. It runs just fine. The site runs with a virtual server that is setup for a 192.168 address at a non reserved port (17000). I have static IP router forwarding to this port which allows access through a url

      e.g. the local access is
      https://192.168.1.120:17000

      and the external access is
      https://myproj.mydomain.com:17000

      Like I said -this works!

      My problem is that I have now installed the latest Jboss

      jboss-4.0.1RC1 with Tomcat 5.0.28

      When I access this through
      https://myproj.mydomain.com:17000

      it gives the following error:
      >>>>>>>>>>>>>>>>
      HTTP Status 404 - /myapp.do

      --------------------------------------------------------------------------------

      type Status report

      message /myapp.do

      description The requested resource (/myapp.do) is not available.


      --------------------------------------------------------------------------------

      Apache Tomcat/5.0.28

      >>>>>>>>>>>>>>>>>>>>>>>>>

      Also when I access it thru the local address
      i.e. https://192.168.1.120:17000

      it works just fine initially but if I redeploy / restart jboss it gives the same error.

      ++++++++++++++++++++++++++++++++++++
      My Apache Virtual Server Config:

      <VirtualHost 192.168.1.120:17000>
      ServerName 192.168.1.120:17000
      DocumentRoot "/usr/local/apache2/htdocs"
      <Directory /usr/local/apache2/htdocs>
      Options None
      AllowOverride all
      Order allow,deny
      Allow from all

      RewriteEngine On
      RewriteRule ^/$ /myapp.do [R]
      SSLEngine on
      SSLProtocol all
      SSLCipherSuite HIGH:MEDIUM
      SSLVerifyClient require
      SSLVerifyDepth 1
      SSLCertificateFile server_cert.pem
      SSLCertificateKeyFile server_key.pem
      SSLCACertificateFile cacert.pem


      my workers2.properties is:

      [channel.socket:localhost:8009]
      info=Ajp13 forwarding over socket
      tomcatId=127.0.0.1:8009

      info=Map the whole webapp
      [uri:/*.do]
      [uri:/myapp]
      [uri:/myapp/]
      [uri:/myapp/*]
      [uri:/*.jsp]

      [shm:]
      info=Scoreboard. Required for reconfiguration and status with multiprocess servers
      file=${serverRoot}/logs/jk2.shm
      size=1048576
      debug=0
      disabled=0


      The only configuration changes I made to the standard jboss binary are:
      - I have created the dbds.xml file for connecting to the database in $JBOSS_HOME/server/default/deploy
      - I have introduced the log4j.xml in server/default/conf

      My understanding is that Apache is forwarding fine to Jboss (as it was with the earlier version of Jboss-Tomcat. Seems to me as though I am missing some configuration on the Jboss-Tomcat side. Am I right? If so what do i need to do ?

      I hope I am posting in the right forum. Apologies if not. (Request you to please direct me to the right forum).

      Thanks