1 Reply Latest reply on Mar 2, 2005 12:15 AM by Fairiz Azizi

    jdbc driver not invoked properly?

    Bart Bremmers Newbie

      This is a new installation using Jboss 4.0.1, postgreSQL 8.0 (driver postgresql-8.0.309.jdbc3.jar) and JDK 1.4. Jboss starts properly but when I try to log in thru openCRX, I get errors. From server.log:
      [STDOUT] loading /WEB-INF/config/bootstrap/101_security_subjects.xml
      [STDOUT] storing 5 objects
      [STDOUT] creating org::opencrx::security::identity1/provider/CRX/segment/Root
      [STDOUT] STATUS: DefaultDomain.MEDIA_ACCESS_FAILURE: (for more info see log)
      and later on lots of erros like this:
      [STDOUT] STATUS: OpenCrxDomain.1003: Requested principal not found. (for more info see log)

      From openCRX.shared.20050120.log:
      BasicException.Entry[0]
      Timestamp=2005-01-20 10:58:02.410
      Class=org.openmdx.compatibility.base.dataprovider.layer.persistence.jdbc.Abst
      ractDatabase_1

      boot.log has no errors.

      I don't know if it's related, but this page "name=jdbc_opencrx_CRX,service=ManagedConnectionPool" from the Jboss management console has some corruption in the html code. Settings are displayed in the table cell, not in the input field box.

      Thanks for any help
      Bart

        • 1. Re: jdbc driver not invoked properly?
          Fairiz Azizi Newbie

          I too get the same error.
          From your logs, it seems you're trying to install opencrx, to no avail.
          I am as well.

          I tried the newly released open crx v1.5 and still get the same error when I try to login.

          Did you figure out the problem?

          It might a jboss security configuration issue, I am not familiar enough with it to diagnose the problem myself.