4 Replies Latest reply on Jan 26, 2005 6:17 AM by Juraj Bobek

    Compiling 3.2.6 under Java 1.3.1 with errors

    Juraj Bobek Newbie

      When I try to compile 3.2.6 under Java 1.3.1 , i get these errors:
      compile-mbean-sources:

      _default:compile-classes:
      [javac] Compiling 520 source files to Z:\Install\JBoss\jboss-3.2.6-src\jmx\o
      utput\classes
      Z:\Install\JBoss\jboss-3.2.6-src\jmx\src\main\javax\management\Query.java:337: v
      alueOf(java.lang.String) in java.lang.Boolean cannot be applied to (boolean)

      return new BooleanValueExp(Boolean.valueOf(value));

      ^

      Z:\Install\JBoss\jboss-3.2.6-src\jmx\src\main\javax\management\loading\MLet.java
      :279: valueOf(java.lang.String) in java.lang.Boolean cannot be applied to (boole
      an)

      Boolean.valueOf(delegateToCLR));

      ^

      Can anybody help me?

        • 1. Re: Compiling 3.2.6 under Java 1.3.1 with errors
          Darran Lofthouse Master

          jbobek,

          This has mostly been answered in your previous post in the beginners corner forum.

          You need to use 3.2.7 to run under jdk 1.3. Try the current release candidate, 3.2.7RC1.


          From the WIKI page you were given a link to in the previous post: -

          Notes on Running JBoss with JDK 1.3.x

          JBoss distributions downloadable from the website may be compiled using newer JDK 1.4.x versions. This has caused problems trying to run the binaries at least with some older JDK 1.3.x versions. Most often these problems manifest themselves at JVM level AbstractMethodErrors or similar.

          To workaround these possible bytecode incompatibilities you will have to rebuild the server from a source checkout using JDK 1.3.x. JBoss 3.2.x series is compatible with JDK 1.3.x and can be compiled with its Java compiler (JBoss 4.x will require JDK 1.4).

          If you find that you get errors (not warnings!) from the compiler trying to create the 3.x server binaries using JDK 1.3.x, please report it as a bug.


          The question that I don't think has been answered yet was where can you get the source. The source is available from: -

          http://sourceforge.net/project/showfiles.php?group_id=22866&package_id=16942&release_id=281293



          • 2. Re: Compiling 3.2.6 under Java 1.3.1 with errors
            Juraj Bobek Newbie

            Yes I read all information from the wiki which was posted.
            After that a tryed to compile 3.2.6. Without succes.

            Now I try to compile 3.2.7 RC1 as you wrote but with a lot of problems again!.
            Many libraries are missing. At this moment I have problem:
            [javac] Compiling 534 source files to Z:\Install\JBoss\jboss-3.2.7RC1-src\jaxrpc\output\classes
            Z:\Install\JBoss\jboss-3.2.7RC1-src\jaxrpc\src\main\org\apache\axis\wsdl\symbolTable\BindingEntry.java:68: cannot resolv
            e symbol

            symbol : class LinkedHashMap

            location: package util

            import java.util.LinkedHashMap;

            ^

            Z:\Install\JBoss\jboss-3.2.7RC1-src\jaxrpc\src\main\org\apache\axis\handlers\EchoHandler.java:67: warning: java.io.Strin
            gBufferInputStream in java.io has been deprecated

            import java.io.StringBufferInputStream;

            ^

            Z:\Install\JBoss\jboss-3.2.7RC1-src\jaxrpc\src\main\org\apache\axis\AxisFault.java:282: cannot resolve symbol

            symbol : method getCause ()

            location: class java.lang.Throwable

            detail = detail.getCause();

            ^

            I ask again. How can I compile some 3.2.x version with Java 1.3.1 without any problems? Is there somewhere some apack of needed libraries?

            Or 3.2.x is only for Java 1.4?

            I am the beginner with JBoss but I need it for my work.

            • 3. Re: Compiling 3.2.6 under Java 1.3.1 with errors
              Darran Lofthouse Master

              I have just been through testing the compilation of JBoss using JDK 1.3.1_02. For the moment I have only been able to do this using Linux but the results I have seen should not be OS specific.

              As already identified the compilation of 3.2.6 fails.
              Also 3.2.7RC1 has some issues compiling the jaxrpc component which results in similar errors to the errors you have reported.

              I have also tried compiling JBoss 3.2.5 and it compiled fine without any errors.

              For the moment I think that 3.2.5 is the latest JBoss version that can be used with JDK 1.3.

              • 4. Re: Compiling 3.2.6 under Java 1.3.1 with errors
                Juraj Bobek Newbie

                Ok I used version 3.2.5. I compiled it without any problems with Java 1.3.1. But when I start JBoss from JBuilder and open JMX console at adress http://localhost:8080/jmx-console/
                a get this error:

                type Exception report

                message

                description The server encountered an internal error () that prevented it from fulfilling this request.

                exception

                javax.servlet.ServletException: com/sun/tools/javac/Main (Unsupported major.minor version 48.0)
                at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:244)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)

                Please where is the problem?