0 Replies Latest reply on Feb 7, 2005 3:14 AM by oguz altun

    build problem

    oguz altun Newbie

      Hi,

      I got JBoss_4_0_2_beta source from the CVS and tried to build it like explained everywhere: start build.bat in the build directory.

      these two were the first of a series of similar errors:

      F:\Profile\Desktop\cvscheckout\jboss-4.0-JBoss_4_0_2_beta\server\output\parsers\org\jboss\ejb\plugins\cmp\ejbql\EJBQLParser.java:352: cannot find symbol
      symbol : variable JJTCOLLECT0ONMEMBERDECLARAT0ON
      location: class org.jboss.ejb.plugins.cmp.ejbql.EJBQLParser
      ASTCollectionMemberDeclaration jjtn000 = new ASTCollectionMemberDeclaration(JJTCOLLECT0ONMEMBERDECLARAT0ON);
      ^
      F:\Profile\Desktop\cvscheckout\jboss-4.0-JBoss_4_0_2_beta\server\output\parsers\org\jboss\ejb\plugins\cmp\ejbql\EJBQLParser.java:352: internal error; cannot instantiate ASTCollectionMemberDeclaration(int) at org.jboss.ejb.plugins.cmp.ejbql.ASTCollectionMemberDeclaration to ()
      ASTCollectionMemberDeclaration jjtn000 = new ASTCollectionMemberDeclaration(JJTCOLLECT0ONMEMBERDECLARAT0ON);

      I have been trying to build different jboss 4.0 revisions now, and always getting error on this JJTSOMETHINGMEMBERDECLARAT0ON thing. As you might guess erroneous file EJBQLParser.java doesn't have the reported code. Just a funny
      /*@bgen(jjtree) Where */
      a little above the reported line number.

      Can sb help me on this?

      And since no body is reporting the same error can successful builders report what OS/JDK/Jboss4.0SourceRevision etc. they used?

      My os: winXp,
      java -version: java version "1.5.0_01"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
      Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode, sharing)
      JBoss version I tried to build: JBoss_4_0_2_beta

      thx.