0 Replies Latest reply on Feb 14, 2005 5:20 AM by neil mitchell

    JCE Configuration Issue

    neil mitchell Newbie

      Hi

      I am using JBoss 4.0.1 and strong JCE I have written some code which encrypts and decrypts a parameter which is passed around my application. The code works fine on JBoss running on my dev Windows box but when I run the EAR on Linux it fails with a

      java.security.KeyStoreException: JCEKS not found;

      I have taken the code that I am running and put it in a simple class which I can execute on Linux outside of JBoss and this works fine so I know all the correct JARs etc are available in the environment and the Security providers are installed.

      I have also written some code which lists all the providers etc and the Algorithm and KeyStore are listed when run in JBoss but I still get this error.

      java.security.KeyStoreException: JCEKS not found;

      I have seen a previous post for JBoss 3.0 that says the JCE jars need to be added to the ejb classpath as JBoss cannot access classes in lib/ext
      http://www.jboss.com/index.html?module=bb&op=viewtopic&t=6957

      Is this the case for 4.0.1? Also how come it works on Windows but not Linux without any modification we are using the same classpath in our start-up scripts?

      Any help or thoughts would be most welcome.


      Cheers


      Neil Mitchell
      Betfair