0 Replies Latest reply on Feb 22, 2005 8:14 AM by Dieu Laurent

    Use JBoss 3.2.6 whit an Oracle 9i database and MyEclipse

    Dieu Laurent Newbie

      Hello, I'me a newbie whith JBoss and I need help to develop EJB

      I've read de pdf document on the main page of JBoss and I have configure this for the oracle-xa-ds.xml


      <xa-datasource>
      <jndi-name>XAOracleDS</jndi-name>
      <track-connection-by-tx/>
      <isSameRM-override-value>false</isSameRM-override-value>
      <xa-datasource-class>oracle.jdbc.xa.client.OracleXADataSource</xa-datasource-class>
      <xa-datasource-property name="URL">jdbc:oracle:thin:@ldieu:1521:security</xa-datasource-property>
      <xa-datasource-property name="User">sys</xa-datasource-property>
      <xa-datasource-property name="Password">leroylaure</xa-datasource-property>
      <!-- Uses the pingDatabase method to check a connection is still valid before handing it out from the pool -->
      <!--valid-connection-checker-class-name>org.jboss.resource.adapter.jdbc.vendor.OracleValidConnectionChecker</valid-connection-checker-class-name-->
      <!-- Checks the Oracle error codes and messages for fatal errors -->
      <exception-sorter-class-name>org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter</exception-sorter-class-name>
      <!-- Oracles XA datasource cannot reuse a connection outside a transaction once enlisted in a global transaction and vice-versa -->
      <no-tx-separate-pools/>
      </xa-datasource>


      <depends optional-attribute-name="TransactionManagerService">jboss:service=TransactionManager




      In the document jboss-service.xml
      I include the line which sets the attribute ?Pad? to ?true?.

      and I change this into the standardjbosscmp-jdbc.xml because there is no jbosscmp-jdbc.xml document in my folders.

      and I put this
      java:/XAOracleDS <datasource-mapping>Oracle9i</datasource-mapping>

      and remove this
      java:/DefaultDS
      <datasource-mapping>Hypersonic SQL</datasource-mapping>

      I restart JBoss and He start corectly. But when I deploy the document
      oracle-xa-ds.xml I havent all the messages tey show into the pdf document. I only have this one :
      INFO [XAOracleDS] Bound connection factory for resource adapter for ConnectionManager 'jboss.jca:service=XATxCM,name=XAOracleDS to JNDI name 'java:/XAOracleDS'

      no other one.

      What can I do to use Jboss whith MyEclipse ??
      I configure it but I receive an error message when I try to start the server, and to deploy my jar !
      this message said:

      the selected server is enabled, but is not configured properly.
      Deployment to it will not be permitted until the probleme is corrected.
      Please navigate to the server preference pages and verify the field whith the prompt: JBoss Home Directory.
      But I don't know where is this page !

      In MyEclipse I configure Xdoclet whith the fallowing elements for JBoss (I préviously add a Standard EJB and Jboss for this one)

      Version I typed 3.2
      datasource I typed java:/security
      datasourceMapping I typed oracle
      and finaly for destDir I typed src/META-INF

      Thank you all for your help.