2 Replies Latest reply on Feb 25, 2005 10:52 AM by Sreedhar Babu

    jboss shutdown error

    Sreedhar Babu Newbie

      Hi,

      I am very sorry for posting the same question again. But as I could not see the reply posted to my original question, I see this is the only option left. Thanks for your patience.

      We have JBoss 3.2.5 running on RHEL AS 3.0. I had changed the default ports jboss uses in all the config files. Startup of jboss is working fine and application is also working fine. But when I execute shutdown.sh -S its giving below exceptions and JBoss is not stopped.
      ---------------------------------
      23:41:35,004 WARN [NamingContext] Failed to connect to localhost:1099
      javax.naming.CommunicationException: Failed to connect to server localhost:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused]]
      at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:213)
      at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1185)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:516)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:509)
      at javax.naming.InitialContext.lookup(InitialContext.java:347)
      at org.jboss.Shutdown.main(Shutdown.java:188)
      Caused by: javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused]
      -----------------------------------

      Please suggest me, what else should I change to avoid these errors.

      thanks and regards,
      Sreedhar.

        • 1. Re: jboss shutdown error
          Scott Stark Master

           

          [starksm@banshee9100 bin]$ shutdown.sh -h
          A JMX client to shutdown (exit or halt) a remote JBoss server.
          
          usage: shutdown [options] <operation>
          
          options:
           -h, --help Show this help message
           -D<name>[=<value>] Set a system property
           -- Stop processing options
           -s, --server=<url> Specify the JNDI URL of the remote server
           -n, --serverName=<url> Specify the JMX name of the ServerImpl
           -a, --adapter=<name> Specify JNDI name of the MBeanServerConnection to
          use
           -u, --user=<name> Specify the username for authentication
           -p, --password=<name> Specify the password for authentication
          
          operations:
           -S, --shutdown Shutdown the server (default)
           -e, --exit=<code> Force the VM to exit with a status code
           -H, --halt=<code> Force the VM to halt with a status code
          


          so, the syntax should be:

          shutdown.sh -s host:port -S
          



          • 2. Re: jboss shutdown error
            Sreedhar Babu Newbie

            thank you very much scott, this worked.

            regards,
            Sreedhar.