1 Reply Latest reply on Jan 10, 2008 10:18 AM by Wendy Bossons

    Problem  in re-rendering the Custom component

    dileep Kumar Newbie

      I have a custom tag that renders a javascript object to the page which basically extends datatable for client side sorting of columns.

      But the default re-renderer appears not to work. I think it might be because of rendering javascript object instead of html content. Any idea to override the default behaviour to extend for javascript as well.


        • 1. Re: Problem  in re-rendering the Custom component
          Wendy Bossons Newbie

          I'm working on a custom component that uses Ajax4Jsf and maybe can help you, but I still am working out an issue where my whole page is rerendering on the submission, rather than just the ajax region. (But it works in a simple web application. Maybe we can help each other.

          I've been able to get the component prototyped and concept proofed in a simple web app, maybe my experience will help you there. And when you're done, please look at my post (see below my signature) to see if you can help me with the issue I'm seeing.

          Can you share more details about this? What Ajax tags are you using, including the AjaxRegion tag?

          Why do you think the default is not working? Any error messages?

          ..\Wendy

          P.S. Please see my post, http://jboss.com/index.html?module=bb&op=viewtopic&t=127361

          to see if you have any feedback for my custom component issue.