1 Reply Latest reply on Mar 25, 2005 8:07 PM by Scott Stark

    JBoss 4.0.1sp1 fails to work when configured for J2EE 1.4 co

    Marco Antonio Villalobos, Jr. Newbie

      This issue has already been addressed in the JIRA for JBoss J2EE 1.4 compliance, under JBAS-1503.

      Anyway, when you follow the directions in the readme.html
      file that ships with JBoss 4.0.1sp1, it seems to have problems
      with certain war files, and log4j, and commons-logging.jar.

      My application, which is an EAR, with EJBs and and a War, seems
      to work when I set

      <attribute name="Java2ClassLoadingCompliance">true</attribute>


      in the jboss web jboss-service.xml file. However, I think this is not
      J2EE 1.4 compliant.