0 Replies Latest reply on Apr 15, 2005 1:57 AM by Geoff Ongley

    Jboss AS 3.2.7 or 4.0.1sp1 on Solaris 10

    Geoff Ongley Newbie

      Hi there,

      I am trying to get JBoss AS to run on Solaris 10. I have had similar issues on Solaris 9.

      I have set the CLASSPATH and JAVA_HOME directories using Sun's jdk 1.4 and 1.5:

      CLASSPATH=/usr/jdk/j2sdk1.4.2_06/lib:/usr/jdk/j2sdk1.4.2_06/jre/lib:/usr/jdk/j2sdk1.4.2_06/jre/lib/ext:.
      JAVA_HOME=/usr/jdk/j2sdk1.4.2_06

      for example.


      The system partially runs:
      =========================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /usr/share/src/jboss-3.2.7

      JAVA: /usr/jdk/j2sdk1.4.2_06/bin/java

      JAVA_OPTS: -server -Dprogram.name=run.sh

      CLASSPATH: /usr/share/src/jboss-3.2.7/bin/run.jar:/usr/jdk/j2sdk1.4.2_06/lib/t
      ools.jar

      =========================================================================
      15:44:53,321 INFO [Server] Starting JBoss (MX MicroKernel)...
      15:44:53,323 INFO [Server] Release ID: JBoss [WonderLand] 3.2.7 (build: CVSTag=
      JBoss_3_2_7 date=200501280217)
      15:44:53,324 INFO [Server] Home Dir: /usr/share/src/jboss-3.2.7
      15:44:53,324 INFO [Server] Home URL: file:/usr/share/src/jboss-3.2.7/
      15:44:53,325 INFO [Server] Library URL: file:/usr/share/src/jboss-3.2.7/lib/
      15:44:53,327 INFO [Server] Patch URL: null
      15:44:53,327 INFO [Server] Server Name: default
      15:44:53,327 INFO [Server] Server Home Dir: /usr/share/src/jboss-3.2.7/server/d
      efault
      15:44:53,327 INFO [Server] Server Home URL: file:/usr/share/src/jboss-3.2.7/ser
      ver/default/
      15:44:53,328 INFO [Server] Server Data Dir: /usr/share/src/jboss-3.2.7/server/d
      efault/data
      15:44:53,328 INFO [Server] Server Temp Dir: /usr/share/src/jboss-3.2.7/server/d
      efault/tmp
      15:44:53,328 INFO [Server] Server Config URL: file:/usr/share/src/jboss-3.2.7/s
      erver/default/conf/
      15:44:53,329 INFO [Server] Server Library URL: file:/usr/share/src/jboss-3.2.7/
      server/default/lib/
      15:44:53,329 INFO [Server] Root Deployment Filename: jboss-service.xml
      15:44:53,334 INFO [Server] Starting General Purpose Architecture (GPA)...
      15:44:53,771 INFO [ServerInfo] Java version: 1.4.2_06,Sun Microsystems Inc.
      15:44:53,772 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.4.2_06-b03
      ,Sun Microsystems Inc.
      15:44:53,772 INFO [ServerInfo] OS-System: SunOS 5.10,sparc
      15:44:54,167 INFO [Server] Core system initialized
      15:44:58,717 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resour
      ce:log4j.xml
      15:44:58,903 INFO [WebService] Using RMI server codebase: http://yamahatma.priv
      :8083/
      15:44:59,210 INFO [NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=
      1098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory=null, Server Socket
      Factory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      15:45:03,191 INFO [Embedded] Catalina naming disabled
      15:45:04,329 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-0.0.0.0
      -8080
      15:45:04,394 INFO [Catalina] Initialization processed in 1090 ms
      15:45:04,395 INFO [StandardService] Starting service jboss.web
      15:45:04,402 INFO [StandardEngine] Starting Servlet Engine: Apache Tomcat/5.0.3
      0
      15:45:04,431 INFO [StandardHost] XML validation disabled
      15:45:04,462 INFO [Catalina] Server startup in 68 ms
      .
      .
      .

      And then I get this error:

      15:45:04,606 INFO [TomcatDeployer] deploy, ctxPath=/invoker, warUrl=file:/usr/s
      hare/src/jboss-3.2.7/server/default/deploy/http-invoker.sar/invoker.war/
      15:45:05,649 ERROR [Engine] StandardContext[/invoker]Exception starting filter R
      eadOnlyAccessFilter
      java.lang.ClassNotFoundException: org.jboss.invocation.http.servlet.ReadOnlyAcce
      ssFilter
      at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
      at org.apache.catalina.core.ApplicationFilterConfig.getFilter(Applicatio
      nFilterConfig.java:211)
      at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(Applica
      tionFilterConfig.java:308)
      at org.apache.catalina.core.ApplicationFilterConfig.(ApplicationFi
      lterConfig.java:79)
      at org.apache.catalina.core.StandardContext.filterStart(StandardContext.
      java:3702)
      .
      .
      .

      and various others. The server gets up and running and you can connect to hostname:8080. However, try the JMX-console and you get a 500 error (Which I presume is because the server never started everything properly).

      With that said, I have also run the exact same extraction of jboss-3.2.7 on a windows machine running jdk1.5.0, and it worked fine without error.

      Another thing I tried was to run the solaris version in 32bits if possible using

      JAVA_OPTS="-d32"

      (This is running on a dual CPU Sparc 64 bit machine)

      I notice a similar problem posted nearby this one... Has anyone seen this/know of how to make it work?

      Thanks