4 Replies Latest reply on May 9, 2005 12:47 PM by Scott Stark

    JBoss 4.0.1sp1 to 4.0.2 upgrade problem

    Sean Whyte Newbie

      I thought this would be a simple upgrade. Download the zip, extract it, change my log4j.xml and jboss-service.xml files, deploy my app, and it doesn't work.

      Here's my specs:
      Windows XP
      Java 1.5.0_02


      I still have 4.0.1sp1 installed and it works with the exact same deployment. However, with 4.0.2 I'm now getting the following error in the tomcat deployer:

      INFO [WebappClassLoader] validateJarFile(C:\dev\rmbm\build\server\rmbm.ear\rmbm-web.war\WEB-INF\lib\j2ee.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
      INFO [STDOUT] log4j:ERROR A "org.jboss.logging.appender.FileAppender" object is not assignable to a "org.apache.log4j.Appender" variable.
      INFO [STDOUT] log4j:ERROR Could not instantiate appender named "FILE".

      It doesn't seem like anything major, but the app starts throwing all sorts of EJB exceptions after that.

      I've tried replacing the j2ee.jar with the latest from Sun.
      I've tried replacing my log4j.jar files with the one that comes in 4.0.2.
      I've looked at different Tomcat settings, since the version has gone from 5.0 to 5.5, but nothing seems to help.

      Some sort of .jar collision? Anybody else seeing this?