0 Replies Latest reply on May 19, 2005 4:13 AM by William Chen

    JSP error on JBOSS 4.0.2 but the same WAR package works OK o

    William Chen Newbie

      Hi,

      I had my web service deployed on JBOSS 3.0.4_tomcat4.1.12 and running without any problem for some months. Then when the latest release JBOSS 4.0.2 AS is out, it might be a good time to refresh and catch up the latest release. Once the 4.0.2 is ready, set and go, I tested it with the standard "jmx-console" browsing which also turned out to be fine. When the same WAR folder is copied across to the second server where the JBOSS 4.0.2 is installed, I got the following error message :

      exception

      org.apache.jasper.JasperException: Unable to compile class for JSP

      Generated servlet error:
      The import LdapBean cannot be resolved

      An error occurred at line: 7 in the jsp file: /LoginBean.jsp
      Generated servlet error:
      LdapBean cannot be resolved or is not a type

      Inside the LoginBean.jsp, it supposes to import LdapBean.class where this file is located at the WEB-INF/classes. One thing that pluzzled me was that it didn't have any error message when the JBOSS 3.0.4 was running.

      the web is running on INTEL plaform with Windows 2000 Server and I believe all the usual system variables (JAVA_HOME and JBOSS_HOME), path, etc. have been set correctly. Just wonder what was causing that error. Could someone shed a light to fix that problem. Help is appreciated.