5 Replies Latest reply on May 31, 2005 7:19 PM by Peter Johnson

    JBOSS Stop Error

    Prajal Sutaria Newbie

      Hi All,

      I am using JBOSS version jboss-3.2.6. I'm able to start jboss properly. my all application server is also running properly on Jboss. but when i try to shutdown the JBOSS i'm not able to do so. Everytime i have to manually kiil the process.

      Check Below Logs.

      [root@webserver bin]# sh shutdown.sh -S
      Exception in thread "main" javax.naming.NameNotFoundException: jmx not bound
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:490)
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:498)
      at org.jnp.server.NamingServer.getObject(NamingServer.java:504)
      at org.jnp.server.NamingServer.lookup(NamingServer.java:248)
      at sun.reflect.GeneratedMethodAccessor46.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:261)
      at sun.rmi.transport.Transport$1.run(Transport.java:148)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.rmi.transport.Transport.serviceCall(Transport.java:144)
      at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
      at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
      at java.lang.Thread.run(Thread.java:534)
      at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
      at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
      at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:133)
      at org.jnp.server.NamingServer_Stub.lookup(Unknown Source)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:530)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:509)
      at javax.naming.InitialContext.lookup(InitialContext.java:347)
      at org.jboss.Shutdown.main(Shutdown.java:188)

      Kindly guide me what is the problem.

      Rgds,
      Prajal

        • 1. Re: JBOSS Stop Error
          Peter Johnson Master

          Try the following:

          sh shutdown.sh -s localhost:1099


          This assumes the default JNDI port of 1099 and that the server is running on your local machine.

          • 2. Re: JBOSS Stop Error
            Peter Johnson Master

            Looking at your error message again, it appears that you do not have the JMX service deployed. Are you running the 'minimal' configuration? That configuration doesn't have JMX, and without JMX you will not be able to remotely stop the server. (When I ran 'minimal' I got the exact same error message you got when running shutdown.)

            • 3. Re: JBOSS Stop Error
              Prajal Sutaria Newbie

              Dear Peter,

              I have got a single tar for jboss, which i have installed on my linux server. Can u pease guide me what do i need to check for JMX service availability. Also let me know what is the quick solution for this.

              • 4. Re: JBOSS Stop Error
                Prajal Sutaria Newbie

                Even after firing sh shutdown.sh -s localhost:1099 also it dosent works. It gives same error. Please guide me what to i need to do to install JMX service.

                • 5. Re: JBOSS Stop Error
                  Peter Johnson Master

                  You will need to copy the jmx-invoker-adaptor-server.sar directory to your deploy directory. You can find a copy in the 'all' and 'default' configurations.

                  Which server configuration are you running? In other words, when you start JBoss as sh run.sh -c XXX, when do you use in place of XXX?

                  What are the contents of that configurations lib and deploy directories?

                  The jmx-invoker-adaptor-server.sar relies on certain jar's being available.

                  Is ther any reason why you cannot deploy your application the the 'default' configuration?