0 Replies Latest reply on Jun 12, 2005 6:57 PM by Ola Theander

    Prblm starting JBoss 4.01 autom. on FreeBSD boot but run.sh

    Ola Theander Newbie

      Dear subscribers

      I?ve just started to evaluate JBoss and my preferred operating system on my servers is FreeBSD 5.3. I?ve managed to get it to run JBoss properly without to much trouble so it now serves .jsp pages, integrates with Apache 2.x via mod_jk without any problems etc. So far so good but there is one small problem that I would like to have some help with. The issue is that I?ve run into some peculiarities trying to have JBoss start automatically when the server boots.

      The problem is that I was forced to edit the ?/usr/local/etc/rc.d/jboss.sh? boot script to get JBoss to start automatically. Normally this script checks if JBoss is supposed to start and if so runs jboss4ctl to start it. For some strange reason jboss4ctl doesn?t start JBoss. It gives no error messages, rather it says that JBoss starts normally. I?ve tried running it from the shell command line with the same result. If I then try to stop JBoss using ?jboss4ctl stop? I get a message saying that JBoss isn?t running.

      If I instead go to the jboss4/bin directory and starts JBoss using ?run.sh? I get a whole bunch of messages and after a while JBoss is up and running, working as far as I can tell perfectly.

      So my temporary solution to the boot problem was to change the ?/usr/local/etc/rc.d/jboss.sh? to use run.sh instead of jboss4ctl and then JBoss starts at boot time. This change worries me a bit though since obviously this isn?t the way it?s supposed to be done and I would like to know if anybody can give me some hint to solve this issue?

      Kind regards, Ola Theander