1 Reply Latest reply on Jul 25, 2005 1:07 AM by vinay purohit

    Exception while deploying in custom config directory: java.s

    vinay purohit Newbie

      I have created a default config (myconfig) and am starting up JBOSS using:

      run -c myconfig

      I have all the required libraries for my web application in jboss-4.0.2\server\myconfig\lib

      When I try to get a connection to the DB from my web application, I do get the connection but also get the following exception:

      10:01:17,285 INFO [STDOUT] |07/25/2005 10:01:17:285 IST|http-0.0.0.0-28080-1|java.sql.Connection|W|Failed to load class: com.jbosstest.dao.
      TestConnect
      java.lang.ClassNotFoundException: No ClassLoaders found for: com.jbosstest.dao.T
      estConnect
      at org.jboss.mx.loading.LoadMgr3.beginLoadTask(LoadMgr3.java:198)
      at org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryCl
      assLoader.java:475)
      at org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassL
      oader.java:377)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:141)


      As a solution that I found on the Net, it was suggested that I have the jboss-remoting.jar in the jboss-4.0.2\server\myconfig\lib. I have it in my directory but it still does not solve the problem. However, this solution works if I deploy my web application in the default directory.

      How do I make this work without getting exception by deploying in myconfig?

      Any replies/solutions will be appreciated.

      cheers
      Vinay

        • 1. Exception while deploying in custom config directory: java.s
          vinay purohit Newbie

           

          "vinaypurohit" wrote:
          I have created a default config (myconfig) and am starting up JBOSS using:

          run -c myconfig

          I have all the required libraries for my web application in jboss-4.0.2\server\myconfig\lib

          When I try to get a connection to the DB from my web application, I do get the connection but also get the following exception:

          10:01:17,285 INFO [STDOUT] |07/25/2005 10:01:17:285 IST|http-0.0.0.0-28080-1|java.sql.Connection|W|Failed to load class: com.jbosstest.dao.
          TestConnect
          java.lang.ClassNotFoundException: No ClassLoaders found for: com.jbosstest.dao.T
          estConnect
          at org.jboss.mx.loading.LoadMgr3.beginLoadTask(LoadMgr3.java:198)
          at org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryCl
          assLoader.java:475)
          at org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassL
          oader.java:377)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
          at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
          at java.lang.Class.forName0(Native Method)
          at java.lang.Class.forName(Class.java:141)


          As a solution that I found on the Net, it was suggested that I have the jboss-remoting.jar in the jboss-4.0.2\server\myconfig\lib. I have it in my directory but it still does not solve the problem. However, this solution works if I deploy my web application in the default directory.

          How do I make this work without getting exception by deploying in myconfig?

          If I include the required libraries in my WEB-INF/lib directory then the exception is not encountered. But I dont want to include the libraries in my WEB-INF/lib directory because these are shared libraries across other web applications and do not want to duplicate them for my web application.

          Any replies/solutions will be appreciated.

          cheers
          Vinay