1 Reply Latest reply on Aug 10, 2005 7:52 AM by Predrag Spasojevic

    jboss 3.2.x and jdk1.3

    Predrag Spasojevic Newbie

      I have problem running jboss 3.2.7 with jdk1.3.1 ( operating system : Windows2000).

      I got following errors in console:

      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: c:\jboss327\bin\\..
      .
      JAVA: c:\java\jdk1.3.1\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat
      .
      CLASSPATH: c:\java\jdk1.3.1\lib\tools.jar;c:\jboss327\bin\\run.jar
      .
      ===============================================================================
      .
      13:02:16,788 INFO [Server] Starting JBoss (MX MicroKernel)...
      13:02:16,788 INFO [Server] Release ID: JBoss [WonderLand] 3.2.7 (build: CVSTag=
      JBoss_3_2_7 date=200501280217)
      13:02:16,788 INFO [Server] Home Dir: C:\jboss327
      13:02:16,788 INFO [Server] Home URL: file:/C:/jboss327/
      13:02:16,788 INFO [Server] Library URL: file:/C:/jboss327/lib/
      13:02:16,788 INFO [Server] Patch URL: null
      13:02:16,788 INFO [Server] Server Name: default
      13:02:16,788 INFO [Server] Server Home Dir: C:\jboss327\server\default
      13:02:16,788 INFO [Server] Server Home URL: file:/C:/jboss327/server/default/
      13:02:16,788 INFO [Server] Server Data Dir: C:\jboss327\server\default\data
      13:02:16,788 INFO [Server] Server Temp Dir: C:\jboss327\server\default\tmp
      13:02:16,788 INFO [Server] Server Config URL: file:/C:/jboss327/server/default/
      conf/
      13:02:16,788 INFO [Server] Server Library URL: file:/C:/jboss327/server/default
      /lib/
      13:02:16,788 INFO [Server] Root Deployment Filename: jboss-service.xml
      13:02:16,804 INFO [Server] Starting General Purpose Architecture (GPA)...
      13:02:17,038 INFO [ServerInfo] Java version: 1.3.1,Sun Microsystems Inc.
      13:02:17,038 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.3.1-b24,Su
      n Microsystems Inc.
      13:02:17,038 INFO [ServerInfo] OS-System: Windows 2000 5.0,x86
      13:02:17,273 INFO [Server] Core system initialized
      13:02:19,601 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resour
      ce:log4j.xml
      13:02:19,710 INFO [WebService] Using RMI server codebase: http://pcpedja:8083/
      13:02:19,882 INFO [NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=
      1098, backlog=50, bindAddress=0.0.0.0/0.0.0.0, Client SocketFactory=null, Server
      SocketFactory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      13:02:22,742 INFO [STDOUT] Can't find resource org.apache.catalina.core.LocalSt
      rings org.jboss.mx.loading.UnifiedClassLoader3@83e1e{ url=file:/C:/jboss327/serv
      er/default/deploy/jbossweb-tomcat50.sar/ ,addedOrder=6}
      13:02:22,742 INFO [STDOUT] [Ljava.net.URL;@30633a
      13:02:22,757 INFO [STDOUT] Can't find resource org.apache.catalina.startup.Loca
      lStrings org.jboss.mx.loading.UnifiedClassLoader3@83e1e{ url=file:/C:/jboss327/s
      erver/default/deploy/jbossweb-tomcat50.sar/ ,addedOrder=6}
      13:02:22,757 INFO [STDOUT] [Ljava.net.URL;@30633a
      13:02:22,757 ERROR [Registry] Error loading jar:file:/C:/jboss327/server/default
      /tmp/deploy/tmp43796catalina.jar!/org/apache/catalina/startup/mbeans-descriptors
      .xml
      13:02:22,757 ERROR [Registry] Error loading jar:file:/C:/jboss327/server/default
      /tmp/deploy/tmp43796catalina.jar!/org/apache/catalina/mbeans-descriptors.xml
      13:02:22,835 INFO [STDOUT] Error
      13:02:22,835 ERROR [BaseModelMBean] Error creating class java.lang.ExceptionInIn
      itializerError
      13:02:22,835 ERROR [Tomcat5] Starting failed jboss.web:service=WebServer
      ReflectionException: Cannot find setter method setCatalinaHome null
      Cause: java.lang.NoSuchMethodException
      at org.apache.commons.modeler.BaseModelMBean.setAttribute(BaseModelMBean
      .java:662)
      at org.jboss.mx.server.RawDynamicInvoker.setAttribute(RawDynamicInvoker.


      The same problem occurs with jboss3.2.5.
      Any idea?