0 Replies Latest reply on Aug 25, 2005 6:06 AM by Tom Coupland

    Jboss hangs on startup

    Tom Coupland Newbie

      Hey everybody,

      Got a problem with my JBoss configuration and can't seem to solve it, hence i've made a post!

      Trying to add my own services to JBoss so they appear inthe JMX management interface. To this end i have implemented the org.jboss.system.ServiceMBeanSupport in the service object (mapshop) and the org.jboss.system.ServiceMBean in the services MBean interface (mapshopMBean). So i've filled out the interfaces, packaged up my code and put it in the lib directory of the server i'm using. Then added the below to jboss-service.xml

      <mbean code="meta.mapshop.MapShop" name="java:\Mapshop">
       <constructor><arg type="java.lang.String" value="java:\Mapshop"></arg></constructor>
       <depends>jboss:service=Naming</depends>
       <depends>jboss.system:type=Log4jService,service=Logging</depends>
      </mbean>
      

      Then when i try and start jboss up gets as far as
      10:53:39,647 INFO [Server] Starting General Purpose Architecture (GPA)...
      10:53:40,750 INFO [ServerInfo] Java version: 1.5.0_03,Sun Microsystems Inc.
      10:53:40,750 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_03-b07,Sun Microsystems Inc.
      10:53:40,750 INFO [ServerInfo] OS-System: Linux 2.6.11-1.27_FC3smp,i386
      10:53:41,707 INFO [Server] Core system initialized
      

      Then stops.. forever (well i left it for 15 minutes and it goes no further). Can anyone help me with this, if seeing my code will help i'l post it to, but left out here for the sake of brevity.

      Also, assuming i get this to work again (it was quite happy yesterday!), i'd like my services to appear in there own sub group, like jboss.admin or jboss.cache, how'd do i go about that?

      Thanks for any thoughts/ideas/solutions

      Tom