1 Reply Latest reply on Sep 16, 2005 6:25 AM by Andy Redhead

    JBoss 4.0.1 (on debian) startup stalls on jdk1.5, ok on jdk1

    Andy Redhead Newbie

      This has been bugging me for a couple of days now...

      I have a cheap "virtual" server run by an ISP which we use to stage applications.

      When I start jboss using the sun j2sdk1.4.2_09 the server starts up ok.

      When I use the sun jdk1.5.0_04, the startup process "stalls" at a random point in the startup process (not always the same point - just somewhere before the applications are deployed).

      The CLASSPATH environmen variable is blank. JAVA_HOME is set to the relevant jdk root directory and JBOSS_HOME is also set.

      This is a "fresh" install, I'm trying to start the default server. The only changes I've made are to set the tomcat parent loader and unified class loader elements to true in the tomcat jboss-service.xml file (not that chaning those values back makes any difference...).

      The console output looks like:

      =========================================================================
      
       JBoss Bootstrap Environment
      
       JBOSS_HOME: /home/reds/sync/pkgs/jboss-4.0.2
      
       JAVA: /home/reds/pkgs/java/jdk1.5.0_04/bin/java
      
       JAVA_OPTS: -server -Xms128m -Xmx128m -Dprogram.name=run.sh
      
       CLASSPATH: /home/reds/sync/pkgs/jboss-4.0.2/bin/run.jar:/home/reds/pkgs/java/jdk1.5.0_04/lib/tools.jar
      
      =========================================================================
      
      08:47:17,222 INFO [Server] Starting JBoss (MX MicroKernel)...
      08:47:17,227 INFO [Server] Release ID: JBoss [Zion] 4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)
      08:47:17,229 INFO [Server] Home Dir: /home/reds/sync/pkgs/jboss-4.0.2
      08:47:17,230 INFO [Server] Home URL: file:/home/reds/sync/pkgs/jboss-4.0.2/
      08:47:17,232 INFO [Server] Library URL: file:/home/reds/sync/pkgs/jboss-4.0.2/lib/
      08:47:17,236 INFO [Server] Patch URL: null
      08:47:17,237 INFO [Server] Server Name: default
      08:47:17,238 INFO [Server] Server Home Dir: /home/reds/sync/pkgs/jboss-4.0.2/server/default
      08:47:17,239 INFO [Server] Server Home URL: file:/home/reds/sync/pkgs/jboss-4.0.2/server/default/
      08:47:17,241 INFO [Server] Server Data Dir: /home/reds/sync/pkgs/jboss-4.0.2/server/default/data
      08:47:17,242 INFO [Server] Server Temp Dir: /home/reds/sync/pkgs/jboss-4.0.2/server/default/tmp
      08:47:17,243 INFO [Server] Server Config URL: file:/home/reds/sync/pkgs/jboss-4.0.2/server/default/conf/
      08:47:17,245 INFO [Server] Server Library URL: file:/home/reds/sync/pkgs/jboss-4.0.2/server/default/lib/
      08:47:17,322 INFO [Server] Root Deployment Filename: jboss-service.xml
      08:47:17,346 INFO [Server] Starting General Purpose Architecture (GPA)...
      08:47:19,095 INFO [ServerInfo] Java version: 1.5.0_04,Sun Microsystems Inc.
      08:47:19,097 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_04-b05,Sun Microsystems Inc.
      08:47:19,098 INFO [ServerInfo] OS-System: Linux 2.4.25-1um,i386
      08:47:21,633 INFO [Server] Core system initialized
      08:47:32,801 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      08:47:35,601 INFO [WebService] Using RMI server codebase: http://openiaa2.miniserver.com:8083/
      08:47:36,954 INFO [NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=1098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory=null, Server SocketFactory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      08:47:55,587 INFO [Embedded] Catalina naming disabled
      


      I'm running out of things to try, anyone have any suggestions?

      Thanks

      Andy.