1 Reply Latest reply on Sep 23, 2005 6:49 AM by Neil Albiston

    Re-deployment problem...revisited.

    Neil Albiston Newbie

      I'm reposting this request for help because my previous thread seems to have got corrupted and I cannot see the replies or reply myself. I apologise for the repost.

      I'll not go into as much detail this time all the details as the deployment xml can be found in post...

      http://www.jboss.com/index.html?module=bb&op=viewtopic&p=3895867#3895867

      Basically an initial deployment works fine. The system is clustered so provides a rock solid service to the main clients...everything is running fine until we need to redeploy.....the undeployment appears to go OK...
      The new ear is copied to the farm directory of one node.
      Each node appears to undeploy and redeploy sucessfullly. There are no errors in the server.log.....but.....

      The new application churns out lots of ???? not bound errors whenever the naming service is called.
      e.g. 2005-09-13 14:48:08,519 INFO [STDOUT] javax.naming.NameNotFoundException: env not bound
      ..
      I've noticed that , in the tmp/deploy directory , the old applications ear file disappears but the old applications ear-contents directory does not. As if something is holding on to part of the old version of the application.

      ...Clue 2 there is also a warning towards the end of the undeployment stage....
      2005-09-13 14:47:59,878 INFO [org.jboss.ejb.EjbModule] Undeployed: CustomPropertiesCmp
      2005-09-13 14:47:59,879 INFO [org.jboss.ejb.EjbModule] Undeployed: CommunitiesCmp
      2005-09-13 14:47:59,880 INFO [org.jboss.ejb.EjbModule] Undeployed: OperatorChargebandsCmp
      2005-09-13 14:47:59,942 INFO [org.jboss.deployment.EARDeployer] Init J2EE application: file:/home/neil/jboss/server/dialogue/farm/200-SamsManager.ear
      2005-09-13 14:48:00,445 WARN [org.jboss.deployment.DeploymentInfo] Only the root deployment can set the loader repository, ingoring config=null
      2005-09-13 14:48:00,454 DEBUG [uk.dialogue.api.sams.mbean.SamsLogsService] Constructor has been executed

      ....
      Shut the jboss server down and restart and everything is fine. But until this little feature has been removed we've lost hot deployment ( which was very nice to have ).

      I'm still searching for an answer to this. I've been trawling google, the forum and the FAQs but to no avail.
      I've read that the warning message may be a bug in 3.2.5 but could be unrelated.
      I also suspect that the ear-contents directory being left behind is a natural feature and is not causing the problems.....but I've no idea what is causing the problems with the JNDI
      ...all the env not bound errors.

      This is affecting our live servers and the sys admins are getting a bit fed up with rebooting the environments every time we redeploy. Its not giving a good impression of jboss.

      any guidance or pointers would be very helpfully received.

      There have been no replies to the previous message for a few days, so either...
      1). No one knows. ( from the info I have provided...so what else do I need to post? )

      2). No one cares...( I'm running an old version and I know we are going to upgrade to 4.02 soon but until then.....please help).

      3). The answer is soooooooooo obvious, I just need to RTFM.... OK flame me. I wont mind. I could even put up with a barrage from Adrian ( and you know how vicious he can get! ) if it pointed me in the right direction. Any pointers appreciated..

      signed Desperate of Sheffield.

        • 1. Re: Re-deployment problem...revisited.
          Neil Albiston Newbie

          No luck...still stuck.... Hot deployment broken....

          I'm clutching at straws ....but I'm running out of ideas.

          Is it something to do with the Deployment scanner config?

          Some of the ??? unbound errors are linked to the URLDeployer I had assumed that this was a secondary symptom rather than the main cause.

          2005-09-22 14:48:45,434 INFO [STDOUT] at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:185)
          2005-09-22 14:48:45,434 INFO [STDOUT] at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:473)
          2005-09-22 14:48:45,434 INFO [STDOUT] at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:176)
          2005-09-22 14:48:45,435 INFO [STDOUT] at $Proxy50.deploy(Unknown Source)
          2005-09-22 14:48:45,435 INFO [STDOUT] at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:304)
          2005-09-22 14:48:45,435 INFO [STDOUT] at org.jboss.ha.framework.server.FarmMemberService.deploy(FarmMemberService.java:374)
          2005-09-22 14:48:45,435 INFO [STDOUT] at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:460)
          2005-09-22 14:48:45,436 INFO [STDOUT] at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:201)
          2005-09-22 14:48:45,436 INFO [STDOUT] at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:212)
          2005-09-22 14:48:45,436 INFO [STDOUT] at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:191)
          2005-09-22 14:48:45,441 INFO [STDOUT] javax.naming.NameNotFoundException: env not bound
          2005-09-22 14:48:45,445 INFO [STDOUT] at org.jnp.server.NamingServer.getBinding(NamingServer.java:495)
          2005-09-22 14:48:45,445 INFO [STDOUT] at org.jnp.server.NamingServer.getBinding(NamingServer.java:503)
          2005-09-22 14:48:45,445 INFO [STDOUT] at org.jnp.server.NamingServer.getObject(NamingServer.java:509)
          2005-09-22 14:48:45,446 INFO [STDOUT] at org.jnp.server.NamingServer.lookup(NamingServer.java:253)
          2005-09-22 14:48:45,446 INFO [STDOUT] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:530)
          2005-09-22 14:48:45,446 INFO [STDOUT] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:509)
          2005-09-22 14:48:45,446 INFO [STDOUT] at uk.dialogue.api.sams.business.ClusterPropertiesClusteredFacadeEJB.useCache(ClusterPropertiesClusteredFacadeEJB.j
          ava:92)

          Here is the Deployment section of the jboss-service .xml..
          ...any clues here?

          
           <!-- ==================================================================== -->
           <!-- The deployers... -->
           <!-- ==================================================================== -->
          
           <!-- EJB deployer, remove to disable EJB behavior-->
           <mbean code="org.jboss.ejb.EJBDeployer" name="jboss.ejb:service=EJBDeployer">
           <attribute name="VerifyDeployments">true</attribute>
           <attribute name="ValidateDTDs">false</attribute>
           <attribute name="MetricsEnabled">false</attribute>
           <attribute name="VerifierVerbose">true</attribute>
          
           <!--
           StrictVerifier: Setting this to 'true' will cause all deployments
           to fail when the Verifier detected a problem with the contained
           Beans.
           -->
           <attribute name="StrictVerifier">false</attribute>
          
           <depends optional-attribute-name="TransactionManagerServiceName">jboss:service=TransactionManager</depends>
           <depends optional-attribute-name="WebServiceName">jboss:service=WebService</depends>
           </mbean>
          
           <!-- EAR deployer, remove if you are not using Web layers -->
           <mbean code="org.jboss.deployment.EARDeployer" name="jboss.j2ee:service=EARDeployer">
           </mbean>
          
           <mbean code="org.jboss.varia.deployment.BeanShellSubDeployer"
           name="jboss.scripts:service=BSHDeployer">
           </mbean>
          
           <mbean code="org.jboss.monitor.EntityLockMonitor"
           name="jboss.monitor:name=EntityLockMonitor"/>
           <mbean code="org.jboss.deployment.scanner.URLDeploymentScanner"
           name="jboss.deployment:type=DeploymentScanner,flavor=URL">
          
           <!-- Uncomment (and comment/remove version below) to enable usage of the
           DeploymentCache
           <depends optional-attribute-name="Deployer">jboss.deployment:type=DeploymentCache</depends>
           -->
           <depends optional-attribute-name="Deployer">jboss.system:service=MainDeployer</depends>
           <attribute name="URLComparator">org.jboss.deployment.DeploymentSorter</attribute>
           <attribute name="Filter">org.jboss.deployment.scanner.DeploymentFilter</attribute>
          
           <attribute name="ScanPeriod">5000</attribute>
          
           <attribute name="URLs">
           deploy/
           </attribute>
          
          
           <attribute name="RecursiveSearch">True</attribute>
           </mbean>