1 Reply Latest reply on Oct 3, 2005 10:17 AM by Gavin Kearney

    Wrong Database file version

    Gavin Kearney Newbie

      When I deploy JBoss4 I get the following error:

      11:18:30,665 ERROR [HypersonicDatabase] Starting failedjboss:database=localDB,service=Hypersonic
      java.sql.SQLException: Wrong database file version
      at org.hsqldb.Trace.getError(Unknown Source)
      at org.hsqldb.Trace.check(Unknown Source)
      at org.hsqldb.Trace.check(Unknown Source)
      at org.hsqldb.Log.open(Unknown Source)
      at org.hsqldb.Database$Logger.openLog(Unknown Source)
      at org.hsqldb.Database.(Unknown Source)
      at org.hsqldb.jdbcConnection.openStandalone(Unknown Source)
      at org.hsqldb.jdbcConnection.(Unknown Source)
      at org.hsqldb.jdbcDriver.connect(Unknown Source)
      at java.sql.DriverManager.getConnection(DriverManager.java:512)
      at java.sql.DriverManager.getConnection(DriverManager.java:171)
      at org.jboss.jdbc.HypersonicDatabase.getConnection(HypersonicDatabase.ja
      va:806)

      It's obviously a DB version compatability problem, but I'm using HSQL version 1.7.2 and I after looking in the ../server/all/data/hypersonic/localDB.properties
      file I saw that that version of HSQL is supported so I'm a bit confused about why I'm getting this problem.

      If anybody has any ideas I would really appreciate any help at all,


      Thanks