0 Replies Latest reply on Oct 3, 2005 3:48 PM by Carl Gundel

    JBOSS server works from command line, but not from the Serve

    Carl Gundel Newbie

      Hi all,

      I have no trouble starting my JBOSS application from the command line using "run -c server", but when I try to start it from the server navigator it throw this:

      14:52:02,312 INFO [SSLContextFactory] Did not find keystore or truststore, initializing SSLContext using neither.
      14:52:02,687 INFO [NamingService] Started jndi bootstrap jnpPort=11099, rmiPort=11098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory=com.pfn.net.ssl.ClientSocketFactory@d74e4396, Server SocketFactory=com.pfn.net.ssl.ServerSocketFactory@1acee78
      14:52:02,718 ERROR [NamingService] Naming accept handler stopping
      javax.net.ssl.SSLException: No available certificate or key corresponds to the SSL cipher suites which are enabled.
       at com.sun.net.ssl.internal.ssl.SSLServerSocketImpl.checkEnabledSuites(SSLServerSocketImpl.java:303)
       at com.sun.net.ssl.internal.ssl.SSLServerSocketImpl.accept(SSLServerSocketImpl.java:253)
       at org.jnp.server.Main$AcceptHandler.run(Main.java:417)
       at org.jboss.util.threadpool.RunnableTaskWrapper.run(RunnableTaskWrapper.java:97)
       at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:743)
       at java.lang.Thread.run(Thread.java:595)


      Any ideas? Why should it work fine when started from the command line but not from Eclipse?

      -Carl