1 Reply Latest reply on Oct 4, 2005 2:56 PM by Othmar Lippuner

    No ClassLoaders found for: org.jboss.naming.NamingService

    Othmar Lippuner Newbie

      Hello,

      I'd like to test/run the jboss.

      After installation I get a dump and the server is not starting correctly.
      Then I shuts down, see the logdump below, with the key message:

      No ClassLoaders found for: org.jboss.naming.NamingService

      Googling the message-subject doesn't help, so I'm here.

      Has anyone have an idea what is wrong. Can you give a helpul hint?
      Thanks for the support
      With kind regards

      Othmar

      C:\prog83\jboss-4.0.2\bin>run
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\prog83\jboss-4.0.2\bin\\..
      .
      JAVA: C:\Programme\Java\jdk1.5.0_04\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
      .
      CLASSPATH: C:\Programme\Java\jdk1.5.0_04\lib\tools.jar;C:\prog83\jboss-4.0.2\bin\\run.jar
      .
      ===============================================================================
      .
      17:01:40,589 INFO [Server] Starting JBoss (MX MicroKernel)...
      17:01:40,599 INFO [Server] Release ID: JBoss [Zion] 4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)
      17:01:40,599 INFO [Server] Home Dir: C:\prog83\jboss-4.0.2
      17:01:40,599 INFO [Server] Home URL: file:/C:/prog83/jboss-4.0.2/
      17:01:40,599 INFO [Server] Library URL: file:/C:/prog83/jboss-4.0.2/lib/
      17:01:40,599 INFO [Server] Patch URL: null
      17:01:40,599 INFO [Server] Server Name: default
      17:01:40,599 INFO [Server] Server Home Dir: C:\prog83\jboss-4.0.2\server\default
      17:01:40,599 INFO [Server] Server Home URL: file:/C:/prog83/jboss-4.0.2/server/default/
      17:01:40,599 INFO [Server] Server Data Dir: C:\prog83\jboss-4.0.2\server\default\data
      17:01:40,619 INFO [Server] Server Temp Dir: C:\prog83\jboss-4.0.2\server\default\tmp
      17:01:40,619 INFO [Server] Server Config URL: file:/C:/prog83/jboss-4.0.2/server/default/conf/
      17:01:40,619 INFO [Server] Server Library URL: file:/C:/prog83/jboss-4.0.2/server/default/lib/
      17:01:40,619 INFO [Server] Root Deployment Filename: jboss-service.xml
      17:01:40,619 INFO [Server] Starting General Purpose Architecture (GPA)...
      17:01:41,360 INFO [ServerInfo] Java version: 1.5.0_04,Sun Microsystems Inc.
      17:01:41,360 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_04-b05,Sun Microsystems Inc.
      17:01:41,360 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      17:01:41,880 INFO [Server] Core system initialized
      17:01:42,051 ERROR [MainDeployer] could not create deployment: file:/C:/prog83/jboss-4.0.2/server/default/conf/jboss-service.xml
      org.jboss.deployment.DeploymentException: No ClassLoaders found for: org.jboss.naming.NamingService; - nested throwable: (java.lang.
      ClassNotFoundException: No ClassLoaders found for: org.jboss.naming.NamingService)
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:143)
      at org.jboss.system.ServiceController.install(ServiceController.java:202)
      ....
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:104)
      ... 33 more
      Failed to boot JBoss:
      org.jboss.deployment.DeploymentException: No ClassLoaders found for: org.jboss.naming.NamingService; - nested throwable: (java.lang.
      ClassNotFoundException: No ClassLoaders found for: org.jboss.naming.NamingService)
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:143)
      ....
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:104)
      ... 33 more
      17:01:42,071 INFO [Server] JBoss SHUTDOWN: Undeploying all packages
      Shutting down
      17:01:42,211 INFO [Server] Shutdown complete
      Shutdown complete
      Halting VM

        • 1. Re: No ClassLoaders found for: org.jboss.naming.NamingServic
          Othmar Lippuner Newbie

          Hey

          I could solve the problem on my own. I was just reluctant about the installation and counted the files and directories.
          Then I erased all files and again did an new unzip of jboss-4.0.2.zip (on win-XP prof)
          Now the whole file is fully unzipped (979 files in 233 dirs).

          C:\prog83\jboss-4.0.2\bin\run.bat
          brings the server now up an running.

          The errormessages dont help a lot. You need to have the right idea
          to solve the problem. Maybe this may help others in similar situations.

          Gruss
          OL