5 Replies Latest reply on Oct 7, 2005 4:26 AM by Simona Pricope

    starting JBoss

    Simona Pricope Newbie

      Hi,

      I have a problem: I start the JBoss server on a computer(p1) and I want to access it from onother computer(p2) but the page cannot be found. I have tried like this:

      http://p1

      The server runs on port 80 so I have tried also http://p1:80, but still no result.

      Thank you

        • 1. Re: starting JBoss
          Darran Lofthouse Master

          By default Tomcat bundled with JBoss is configured to listen on port 8080 no port 80 so your URL will need to be http://p1:8080

          Alternatively you can change the port in {jboss.home}/server/default/deploy/jbossweb-tomcat55.sar/server.xml

          • 2. Re: starting JBoss
            Simona Pricope Newbie

            Thank for your answer, but I want to get it running on port 80, so that's why I have changed myself the {jboss.home}/server/default/deploy/jbossweb-tomcat55.sar/server.xml and the jboss-service.xml files. I want to use the 80 port because I want that everyone can access my project and I think (I am not sure that when I will be using the 8080 port I will have problems with Windows Firewall)

            So..is there any posibility to have on port 80?

            • 3. Re: starting JBoss
              Darran Lofthouse Master

              Sorry I dont understand your last post.

              What changes have you actually made?

              If you look in the file I mentioned in my last post you will find ' <Connector port="8080" ' it is this that will need changing to 80 instead of 8080.

              You shouldn't need to change other configuration files to get tomcat to listen on port 80.

              If you think you are having problems with Windows firewall it will be better to switch it off and make sure you can get JBoss working as required then enable the firewall and sort out the configuration. If you are new to this then trying to configure both at once is going to be difficult.

              • 4. Re: starting JBoss
                Simona Pricope Newbie

                So, I have changed the server.xml file to use the port 80. My connector tag looks like that:
                <!-- A HTTP/1.1 Connector on port 80 -->


                So, when I start the JBoss server on my machine, I can access it with http://localhost or http://localhost:80 is the same thing. But when I'm trying to start the JBoss on another computer(p1) and try to access it from my computer with http://p1 it doesn'nt work. So did you say something about another configurations? I will also try to stop the firewall, to see what happens.

                • 5. Re: starting JBoss
                  Simona Pricope Newbie

                  Hello,

                  Now it works :). Thanks alot. I have set the firewall, with permissions for port 80.