3 Replies Latest reply on Oct 26, 2005 11:43 AM by Brad Millett

    Error on Startup

    Brad Millett Newbie

      I am helping a coworker install JBoss and we are having a problems. THis has worked on my Mac with the same config so we are confused. We have installed JBoss (4.0.3) both from the ".zip" download and the "installer jar file." (both installations give the same error) However, after installation when we try and run JBoss we get the error displayed below. We are running the default server with no changes made to anything in JBoss. The system is Mac OSX 10.4.2, with the latest (1.4.2_9) jvm.


      I found a previous thread that discussed the same problem, but it was for JBoss version 3.2.X and the user was running a 1.5 jvm. The answer to that user was the java 1.5 wasn't supported on JBoss 3.2.X. As I am running JBoss 4.0.3 and a 1.4.2 jvm this didn't help. Any ideas of what I could be doing wrong? Thanks in advance.



      =========================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /Users/mikedonnelly/Desktop/jboss-4.0.3

      JAVA: java

      JAVA_OPTS: -server -Xms128m -Xmx128m -Dprogram.name=run.sh

      CLASSPATH: /Users/mikedonnelly/Desktop/jboss-4.0.3/bin/run.jar:/lib/tools.jar

      =========================================================================

      14:41:24,945 INFO [Server] Starting JBoss (MX MicroKernel)...
      14:41:24,948 INFO [Server] Release ID: JBoss [Zion] 4.0.3 (build: CVSTag=JBoss_4_0_3 date=200510042324)
      14:41:24,963 INFO [Server] Home Dir: /Users/mikedonnelly/Desktop/jboss-4.0.3
      14:41:24,963 INFO [Server] Home URL: file:/Users/mikedonnelly/Desktop/jboss-4.0.3/
      14:41:24,965 INFO [Server] Patch URL: null
      14:41:24,966 INFO [Server] Server Name: default
      14:41:24,966 INFO [Server] Server Home Dir: /Users/mikedonnelly/Desktop/jboss-4.0.3/server/default
      14:41:24,966 INFO [Server] Server Home URL: file:/Users/mikedonnelly/Desktop/jboss-4.0.3/server/default/
      14:41:24,967 INFO [Server] Server Temp Dir: /Users/mikedonnelly/Desktop/jboss-4.0.3/server/default/tmp
      14:41:24,968 INFO [Server] Root Deployment Filename: jboss-service.xml
      Failed to boot JBoss:
      javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepository,name=Default
      at com.sun.management.jmx.MBeanServerImpl.getMBean(MBeanServerImpl.java:1678)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1522)
      at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:599)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:397)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:330)
      at org.jboss.Main.boot(Main.java:187)
      at org.jboss.Main$1.run(Main.java:438)
      at java.lang.Thread.run(Thread.java:552)



        • 1. Re: Error on Startup
          Brad Millett Newbie

          Digging in the Boot.log I noticed the following line:


          14:41:25,071 DEBUG [Server] Created MBeanServer: com.sun.management.jmx.MBeanServerImpl@9ccb73


          Shouldn't that read:


          15:34:02,013 DEBUG [Server] Created MBeanServer: org.jboss.mx.server.MBeanServerImpl@2bae98[ defaultDomain='jboss' ]


          Does anyone now why the sun MBeanServer would load instead of the JBoss one? Any ideas on how to force it to load the JBoss MBeanServer?

          • 2. Re: Error on Startup
            Scott Stark Master

            You have to be picking up a java5 vm as there is no other way you are creating the bundled sun mbean server. The only other way this can happen is if the jdk has the jmx libraries added as an endorsed extension.

            • 3. Re: Error on Startup
              Brad Millett Newbie

              That was it! Thanks!

              My coworker had a jar file in his java Extensions directory that contained the sun mbean server. We removed it and he was able to boot correctly. That explains why it worked on my computer and not his.