4 Replies Latest reply on Dec 7, 2005 11:00 AM by a a

    problem of starting server on the machine with biprocessors

    dou lei Newbie

      I used to start jboss-4.0.2 server without any problem on the machine with one processor and win2000 professional OP.
      However, when I start the same server on the machie with biprocessors and win2000 advanced server OP, there're some problems.

      For both situation, I set the hsqldb as the defaultDS. The corresponding configuration in hsqldb-ds.xml is as followed:
      <connection-url>jdbc:hsqldb:hsql://localhost:1701</connection-url>

      1701
      true
      default
      false
      true


      When I start the server on the machine with biprocessor, the error message is as followed:
      09:56:02,000 INFO [STDOUT] [Server@1ed00d1]: [Thread[hypersonic-default,5,jboss]]: checkRunning(false) entered
      09:56:02,015 INFO [STDOUT] [Server@1ed00d1]: [Thread[hypersonic-default,5,jboss]]: checkRunning(false) exited
      09:56:02,015 INFO [STDOUT] [Server@1ed00d1]: Startup sequence initiated from main() method
      09:56:02,015 INFO [STDOUT] [Server@1ed00d1]: Loaded properties from [D:\jboss-4.0.2\bin\server.properties]
      09:56:02,015 INFO [STDOUT] [Server@1ed00d1]: Initiating startup sequence...
      09:56:02,015 INFO [STDOUT] [Server@1ed00d1]: Server socket opened successfully in 0 ms.
      09:56:02,187 INFO [STDOUT] [Server@1ed00d1]: Database [index=0, id=1, db=file:D:\jboss-4.0.2\server\default\data\hypersonic\default
      , alias=] opened sucessfully in 156 ms.
      09:56:02,187 INFO [STDOUT] [Server@1ed00d1]: Startup sequence completed in 172 ms.
      09:56:02,187 INFO [STDOUT] [Server@1ed00d1]: 2005-11-18 09:56:02.187 HSQLDB server 1.8.0 is online
      09:56:02,187 INFO [STDOUT] [Server@1ed00d1]: To close normally, connect and execute SHUTDOWN SQL
      09:56:02,203 INFO [STDOUT] [Server@1ed00d1]: From command line, use [Ctrl]+[C] to abort abruptly
      09:56:02,343 INFO [WrapperDataSourceService] Bound connection factory for resource adapter for ConnectionManager 'jboss.jca:service
      =DataSourceBinding,name=DefaultDS to JNDI name 'java:DefaultDS'
      09:56:02,500 ERROR [GeneralPurposeDatabasePersistencePlugin] Cannot create timer table
      org.jboss.deployment.DeploymentException: Error while checking if table aleady exists TIMERS; - nested throwable: (java.sql.SQLExcep
      tion: Table not found: SYSTEM_TABLES in statement [SELECT * FROM SYSTEM_TABLES])
      ............................


      After the server is started, I run the database manager, and find it look's like dead. The flag of "ready" is red. And I couldn't invoke any button on it's UI.

      I have searched all relative information in the forum, and find that someone said it's due to the hyperthreading. So I disable it and start the server again. This time the same error occus. However, something different happened. When I run the database manager this time, it work normally. The flag of "ready" is green. And it reports the SQL exception of finding no system tables.

      Why the system table is not created?
      Does this have something to do with the biprocessors?
      How to settle this problem?

      Thanks a lot!