0 Replies Latest reply on Dec 27, 2005 4:34 AM by luke hinds

    Ubuntu Installation

    luke hinds Newbie

      Hi,

      I am having some problems installing the jboss app server on a ubuntu installation.

      The first error i encountered was:

      Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
       at ._ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang5ErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java3awt8AWTErrorC1EPNS_4lang6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java3awt7Toolkit17getDefaultToolkitEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java3awt4Font2tkEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java3awt4Font18getPeerFromToolkitEPNS_4lang6StringEPNS_4util3MapE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java3awt4FontC1EPNS_4lang6StringEii (/usr/lib/libgcj.so.6.0.0)
       at ._ZN5javax5swing4plaf14FontUIResourceC1EPN4java4lang6StringEii (/usr/lib/libgcj.so.6.0.0)
       at ._ZN5javax5swing4plaf5metal17DefaultMetalTheme18__U3c_clinit__U3e_Ev (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang5Class15initializeClassEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN5javax5swing4plaf5metal16MetalLookAndFeel18createDefaultThemeEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN5javax5swing4plaf5metal16MetalLookAndFeelC1Ev (/usr/lib/libgcj.so.6.0.0)
       at ._ZN5javax5swing9UIManager18__U3c_clinit__U3e_Ev (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang5Class15initializeClassEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN10_Jv_Linker18resolve_pool_entryEPN4java4lang5ClassEi (/usr/lib/libgcj.so.6.0.0)
       at com.izforge.izpack.installer.GUIInstaller.loadLookAndFeel() (Unknown Source)
       at ._ZN16_Jv_InterpMethod10run_normalEP7ffi_cifPvP7ffi_rawS2_ (/usr/lib/libgcj.so.6.0.0)
       at com.izforge.izpack.installer.GUIInstaller.GUIInstaller() (Unknown Source)
       at ._ZN16_Jv_InterpMethod10run_normalEP7ffi_cifPvP7ffi_rawS2_ (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang5Class11newInstanceEv (/usr/lib/libgcj.so.6.0.0)
       at com.izforge.izpack.installer.Installer.main(java.lang.String[]) (Unknown Source)
       at ._ZN16_Jv_InterpMethod9run_classEP7ffi_cifPvP7ffi_rawS2_ (/usr/lib/libgcj.so.6.0.0)
       at ._ZN3gnu4java4lang10MainThread9call_mainEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN3gnu4java4lang10MainThread3runEv (/usr/lib/libgcj.so.6.0.0)
       at ._Z13_Jv_ThreadRunPN4java4lang6ThreadE (/usr/lib/libgcj.so.6.0.0)
       at ._Z11_Jv_RunMainP14_Jv_VMInitArgsPN4java4lang5ClassEPKciPS6_b (/usr/lib/libgcj.so.6.0.0)
       at .main (/usr/lib/libgij.so.6.0.0)
       at .__libc_start_main (/lib/tls/i686/cmov/libc-2.3.5.so)
      Caused by: java.lang.ClassNotFoundException: gnu.java.awt.peer.gtk.GtkToolkit not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:jboss-4.0.3SP1-installer.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
       at ._ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang9ThrowableC1EPNS0_6StringEPS1_ (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang9ExceptionC1EPNS0_6StringEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang22ClassNotFoundExceptionC1EPNS0_6StringEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang22ClassNotFoundExceptionC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java3net14URLClassLoader9findClassEPNS_4lang6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang11ClassLoader9loadClassEPNS0_6StringEb (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang11ClassLoader9loadClassEPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
       at ._Z13_Jv_FindClassP13_Jv_Utf8ConstPN4java4lang11ClassLoaderE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang5Class7forNameEPNS0_6StringEbPNS0_11ClassLoaderE (/usr/lib/libgcj.so.6.0.0)
       at ._ZN4java4lang5Class7forNameEPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
       ...25 more
      


      So i installed libgcj6-awt


      # apt-get install libgcj6-awt
      Reading package lists... Done
      Building dependency tree... Done
      The following NEW packages will be installed:
       libgcj6-awt
      0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0B/226kB of archives.
      After unpacking 762kB of additional disk space will be used.
      
      Preconfiguring packages ...
      Selecting previously deselected package libgcj6-awt.
      (Reading database ... 59295 files and directories currently installed.)
      Unpacking libgcj6-awt (from .../libgcj6-awt_4.0.1-4ubuntu9_i386.deb) ...
      Setting up libgcj6-awt (4.0.1-4ubuntu9) ...
      


      Which got me step further but not enough:


      $ java -jar jboss-4.0.3SP1-installer.jar
      PackageListener, install.log=/home/jboss/install.log
      Cannot create log: /home/jboss/install.log
      
      (.:8183): GdkPixbuf-CRITICAL **: gdk_pixbuf_new: assertion `width > 0' failed
      
      ** ERROR **: file ../../../src/libjava/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkImage.c: line 572 (createRawData): assertion failed: (data_fid != 0)
      aborting...
      Aborted
      


      Here are some stats:

      Kernel:

      2.6.12-10-386


      java version "1.4.2"gij (GNU libgcj) version 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)