2 Replies Latest reply on Jan 6, 2006 6:57 AM by Dimitris Andreadis

    JBoss 4.0.2 Startup problem

    Srinivas Velidanda Newbie

      Hi,

      I am new to JBoss, earlier I worked with Weblogic/Web Services and am interested to work with JBoss.

      But The first time I downloaded and tried to start the JBoss Server I am getting errors, can someone help me to fix this bug.

      Following is the error log while running the \bin\run.bat file.

      I am Using JBoss 4.0.2

      ************************
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\jboss-4.0.2\bin\\..
      .
      JAVA: C:\j2sdk1.4.2\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
      .
      CLASSPATH: C:\j2sdk1.4.2\lib\tools.jar;C:\jboss-4.0.2\bin\\run.jar
      .
      ===============================================================================
      .
      16:47:33,642 INFO [Server] Starting JBoss (MX MicroKernel)...
      16:47:33,642 INFO [Server] Release ID: JBoss [Zion] 4.0.2 (build: CVSTag=JBoss_
      4_0_2 date=200505022023)
      16:47:33,642 INFO [Server] Home Dir: C:\jboss-4.0.2
      16:47:33,642 INFO [Server] Home URL: file:/C:/jboss-4.0.2/
      16:47:33,642 INFO [Server] Library URL: file:/C:/jboss-4.0.2/lib/
      16:47:33,642 INFO [Server] Patch URL: null
      16:47:33,642 INFO [Server] Server Name: default
      16:47:33,642 INFO [Server] Server Home Dir: C:\jboss-4.0.2\server\default
      16:47:33,642 INFO [Server] Server Home URL: file:/C:/jboss-4.0.2/server/default
      /
      16:47:33,642 INFO [Server] Server Data Dir: C:\jboss-4.0.2\server\default\data
      16:47:33,657 INFO [Server] Server Temp Dir: C:\jboss-4.0.2\server\default\tmp
      16:47:33,657 INFO [Server] Server Config URL: file:/C:/jboss-4.0.2/server/defau
      lt/conf/
      16:47:33,657 INFO [Server] Server Library URL: file:/C:/jboss-4.0.2/server/defa
      ult/lib/
      16:47:33,657 INFO [Server] Root Deployment Filename: jboss-service.xml
      16:47:33,657 INFO [Server] Starting General Purpose Architecture (GPA)...
      Failed to boot JBoss:
      javax.management.InstanceNotFoundException: JMImplementation:name=Default,servic
      e=LoaderRepository
      at com.sun.management.jmx.MBeanServerImpl.getMBean(MBeanServerImpl.java:
      1680)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:15
      24)
      at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:
      580)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:378)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:315)
      at org.jboss.Main.boot(Main.java:195)
      at org.jboss.Main$1.run(Main.java:463)
      at java.lang.Thread.run(Thread.java:534)
      Press any key to continue . . .
      ************************

      I am frustrated the FIRST DAY itself, wish me success working with JBoss further.

      thanks to all JBoss Users
      Srinivas.

        • 1. Re: JBoss 4.0.2 Startup problem
          Srinivas Velidanda Newbie

          I don't understand what kind of forum is this.

          before posting my question I searched forum but couldn't find any relevant solution for my problem, which is really very basic.

          I found the solution myself as I tried to use higher version of JDK and got the server running.

          I was using JAVA_HOME pointed to J2SDK 1.4.2 and was unable to start the server with the reported bug.

          Now I changed JAVA_HOME to bea supplied jdk, jdk142_04, got the server up and running.

          this would help lot many starters of JBoss.

          anyway thanks to JBoss AS as it started without any errors..

          I wish all the best to myself.

          Srinivas.

          • 2. Re: JBoss 4.0.2 Startup problem
            Dimitris Andreadis Master

            There is no guarantee whatsoever for any free forum to provide you with an answer to any basic problem you may have, especially within 30' which is the time difference between your 2 posts.