1 Reply Latest reply on Jan 16, 2006 10:52 AM by Gonenc Ercan

    Shared Objects in Hp Unix

    Gonenc Ercan Newbie

      Well I am trying to deploy an web application which (not an enterprise project, dynamic web project) uses a shared object ".so" files. We are using JBoss 4.0.2 and OS is HP-UX. We have tried to deploy this application on a Windows machine (Test) and we have succeeded. However in production machine (HP-UX) we have configured the LD_LIBRARY_PATH and SHLIB_PATH variables. We have tested the ".so" files as standalone console application and it works. However when we run the same code from a web page code fails and throws an;

      Unsatisifed Link Error '/correctPath/xxx.so' unable to load module : Bad Magic Number.

      I have tried the same on a tomcat 5.0 and it works on the same machine. So the shared libraries can not be reached from the JBoss. I have checked the permissions for the shared objects and have granted full permissions for everyone. I know that .so files are not corrupt, since it runs from other applications.

      It is kinda urgent and any pointers, ideas are highly welcomed.

      Thanks in advance