2 Replies Latest reply on Mar 27, 2006 9:28 PM by Russ

    New to JBoss and Server is not working--Please Help

    Russ Newbie

      I will tell you I am very new so I don't understand everything about the app server. I originally installed the server and had everything deploying properly, but now something is wrong involed with the logger.

      When JBoss AS comes up the screen displayes this error .

      
      C:\jboss-4.0.3SP1\bin>run
      ===============================================================================
      .
       JBoss Bootstrap Environment
      .
       JBOSS_HOME: C:\jboss-4.0.3SP1\bin\\..
      .
       JAVA: C:\java\j2sdk1.4.2_11\bin\java
      .
       JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
      .
       CLASSPATH: C:\java\j2sdk1.4.2_11\lib\tools.jar;C:\jboss-4.0.3SP1\bin\\run.jar
      .
      ===============================================================================
      .
      07:11:31,031 INFO [Server] Starting JBoss (MX MicroKernel)...
      07:11:31,031 INFO [Server] Release ID: JBoss [Zion] 4.0.3SP1 (build: CVSTag=JBoss_4_0_3_SP1 date=200510231751)
      07:11:31,046 INFO [Server] Home Dir: C:\jboss-4.0.3SP1
      07:11:31,046 INFO [Server] Home URL: file:/C:/jboss-4.0.3SP1/
      07:11:31,046 INFO [Server] Patch URL: null
      07:11:31,046 INFO [Server] Server Name: default
      07:11:31,046 INFO [Server] Server Home Dir: C:\jboss-4.0.3SP1\server\default
      07:11:31,046 INFO [Server] Server Home URL: file:/C:/jboss-4.0.3SP1/server/default/
      07:11:31,046 INFO [Server] Server Temp Dir: C:\jboss-4.0.3SP1\server\default\tmp
      07:11:31,046 INFO [Server] Root Deployment Filename: jboss-service.xml
      07:11:31,359 INFO [ServerInfo] Java version: 1.4.2_11,Sun Microsystems Inc.
      07:11:31,359 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.2_11-b06,Sun Microsystems Inc.
      07:11:31,359 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      07:11:31,750 INFO [Server] Core system initialized
      07:11:32,953 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      07:11:32,968 WARN [ServiceController] Problem creating service jboss.system:service=Logging,type=Log4jService
      java.lang.NoClassDefFoundError: org/apache/log4j/xml/DOMConfigurator
      



      Thanks in advance for any suggestions.

      Russ