5 Replies Latest reply on Apr 20, 2006 9:36 AM by Alexander Sack

    JBoss 4.0.3SP1 not honoring Extension-List versioning?

    Alexander Sack Novice

      I have two EARs that were built against a common JAR library that defines the following MANIFEST in my-lib.jar:

      Extension-Name: my-lib
      Implementation-Version: 1.0

      I then have my.ear with a EJB3 my.jar in it that has the following MANIFEST.MF:

      Extension-List: my-lib
      my-lib-Extension-Name: my-lib
      my-lib-Implementation-Version: 2.0

      This works! Shouldn't this fail with a java Exceptino at load/runtime with NoClassDefFound for all the classes defined in my-lib version 1.0 since the implementation version is 2.0?

      Thanks!