2 Replies Latest reply on Jun 2, 2006 2:41 PM by Richard Knechtel

    Suse 10 : bad argument for IP_MULTICAST_IF

    Smith Aron Newbie

      Hi,

      I am so close, yet so far to get the latest production release of JBoss up and running on a fresh install of Suse 10.

      I installed Java 1.5 with the JAVA_HOME set properly.

      When I start the server it scrolls many stack traces all starting with the error:

      java.net.SocketException: bad argument for IP_MULTICAST_IF: address not
      bound to any interface

      I have no clue how to troubleshoot this?

      thanks

      A

        • 1. Re: Suse 10 : bad argument for IP_MULTICAST_IF
          Alex Titov Newbie

          To solve this problem you need to correct your jboss/bin/run.sh :
          before:

          -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" \
          -classpath "$JBOSS_CLASSPATH" \
          org.jboss.Main "$@"
          


          after:
          -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" \
          -classpath "$JBOSS_CLASSPATH" \
          -Djava.net.preferIPv4Stack=true \
          org.jboss.Main "$@"
          


          So, the row
          -Djava.net.preferIPv4Stack=true \
          must be added
          There is no spaces must be after \

          • 2. Re: Suse 10 : bad argument for IP_MULTICAST_IF
            Richard Knechtel Newbie

            I'm running JBoss on SuSe 10 as well. I didn't change the run.sh but I just added "--host=127.0.0.1" paramter to the run.sh command. (change 127.0.0.1 to the IP address of your machine) this is how I run it and it works great!

            I'm going to try the run.sh change to see how well that works.

            Basically I run a script that does it, something like this:
            nohup bin/run.sh -c $APP --host=$HOST >/dev/null 2>&1 &