1 Reply Latest reply on May 30, 2006 6:19 PM by Anders Carlsen

    Jboss 4.0.3, Firebird 1.5.3.4870 and Windows 2003 server on

    Anders Carlsen Newbie

      I have this very annoying problem, and I hope somebody here will be able to point me in the right direction, because I feel like I have tried just about everything.

      Basicially our setup is, that we have two servers, both Windows 2003 Server running on VMware. The one server is running as a JBoss application server while the other is used as a dedicated Firebird database server.

      This setup has previously run for years on two dedicated servers (not VMware) without any problems, and the goal is now to migrate the application to the VMware servers. The problem is, that when we try to run this setup we get, at totally random it seems, this error:

      org.jboss.tm.JBossRollbackException: Unable to commit, tx=TransactionImpl:XidImpl[FormatId=257, GlobalId=appname/3469, BranchQual=, localId=3469] status=STATUS_NO_TRANSACTION;


      I happens sometime after a day, sometime after 10 minutes and it totally crashes the application. However, if I install firebird on the same server as jboss with exactly the same settings as the Firebird I installed on the db server, and simply point my J2EE application towards localhost instead of my dbserver, then everything works fine and keeps working fine, even under extremely heavy load.

      I have tried reinstalling Jboss and firebird multiple times (and different versions), I have tried tons of different datasource configurations (and I have a strong feeling it has nothing to do with that anyway, since it have worked fine on our production server for quite a while). The only thing that is different is the OS, Windows 2003 Server vs Windows 2000 Server, and that the former is running on VMWare... any help will be greatly appreciated.