1 Reply Latest reply on May 30, 2006 10:39 AM by Andris Birkmanis

    Does JBoss 4.0.4 support Java EE 5?

    Andris Birkmanis Newbie

      I am trying to deploy a really simple EAR to JBoss 4.0.4 GA, and I have the following exception:
      org.jboss.deployment.DeploymentException: No META-INF/application.xml found
      at org.jboss.deployment.EARDeployer.init(EARDeployer.java:133)
      at org.jboss.deployment.MainDeployer.init(MainDeployer.java:861)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:798)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:771)
      I have to admit that the EAR does not contain application.xml, but if my understanding of the spec is correct, this is a normal situation (e.g., section EE.8.4.2 Deploying a Java EE Application). Do I miss some configuration trick, or the full support of EE 5 is scheduled for later versions of JBoss AS?

      Or should I create a bug report?

      Thanks