3 Replies Latest reply on Jun 26, 2007 12:56 PM by Sergey Smirnov

    Seam's EL enhancement not working in Richfaces Snapshot

    Christian Urban Newbie

      Hello,

      I am using latest versions of Seam, Ajax4jsf and Richfaces.

      Within my app I am using the EL enhancement provided by Seam, which facilitates me to call a method with parameters in a JSF method binding.

      Here is the code of my xhtml page:

      <rich:dataTable id="crossSellingTable" columnClasses="ProductNumber, ProductName, Prize" styleClass="CrossSellingList" border="0" cellpadding="0" cellspacing="0" var="crossSellingProduct" value="#{referenceProductList}">
      
       <rich:column colspan="3" styleClass="CrossSellingSubTableHeader">#{crossSellingProduct.productNumber} - #{crossSellingProduct.name}</rich:column>
      
       <rich:subTable id="crossSellingSubTable" var="selectedProduct" value="#{crossSellingProduct.referenceProducts}" >
       <rich:column>
       <f:facet name="header">#{messages['view.table.header.productNumber']}</f:facet>
       <a4j:commandLink styleClass="UnderlineNone" id="selectCrossSellingCommand1" actionListener="#{orderAction.selectReferenceProduct(selectedProduct)}" reRender="orderPartList">#{selectedProduct.productNumber}</a4j:commandLink>
       </rich:column>
       <rich:column>
       <f:facet name="header">#{messages['view.table.header.result']}</f:facet>
       <a4j:commandLink styleClass="UnderlineNone" id="selectCrossSellingCommand2" actionListener="#{orderAction.selectReferenceProduct(selectedProduct)}" reRender="orderPartList">#{selectedProduct.name}</a4j:commandLink>
       </rich:column>
       <rich:column>
       <f:facet name="header">#{messages['view.table.header.singlePrize']}</f:facet>
       <a4j:commandLink styleClass="UnderlineNone" id="selectCrossSellingCommand3" actionListener="#{orderAction.selectReferenceProduct(selectedProduct)}" reRender="orderPartList">#{selectedProduct.prize}</a4j:commandLink>
       </rich:column>
       </rich:subTable>
      
      </rich:dataTable>
      


      Due to error http://jira.jboss.com/jira/browse/RF-2 I was trying the actual snapshot builds.
      Unfortunately the method calls with parameters stopped working with the snapshot builds.
      It worked fine with 3.0.0

      Any ideas? Thanks in advance.