8 Replies Latest reply on Jul 6, 2006 3:42 PM by Sabrina Schurhaus

    Problem creating service jboss.system:Service=MainDeployer

    Lance Drake Newbie

      Hi JBoss Folks,

      In attempting to launch JBoss 4.0.4 in Fedora (FC5-i386) a error is generated which I am not sure how to remedy. As the subject of this posting says, "Problem creating service jboss.system:Service=MainDeployer".

      The subsequent error indicates: java.lang.NoClassDefFoundError"

      I am thinking that JBoss does not know how to get ahold of Java. The mention in the JBoss installation instructions says to 'export JAVA_HOME=/Path/to/JavaSDK'. So, I downloaded 'j2SDK-1.4.2_12-linux-i586.bin' - but that does not appear to be 'good to go' - and I'm not really sure what to do with it.

      Can anyone help with a vector to any info for dealing with the question of 'connecting JBoss to Java in the Fedora environment'?

      THANKS!

        • 1. Re: Problem creating service jboss.system:Service=MainDeploy
          Peter Johnson Master

          I have JBoss running on FC5. It would help if you posted the full console output so that I could see what class is missing. I do know that JBoss will not run with the JVM that ships with FC5, you will need to download and install a JVM from Sun before you can use JBoss.

          • 2. Re: Problem creating service jboss.system:Service=MainDeploy
            Lance Drake Newbie

            Hi

            THANKS for the quick response. As with so many such alleged brick-walls, this problem was dispensed after the instructions were located that explained how to get the JDK, unpacked, into position, and locatable.

            Call this one CLOSED/SOLVED/RESOLVED.

            For the archives - the solution-trail begins at the Sun doc: "Java 2 SDK 1.4.2 Installation Notes for Linux" -

            Nice to know there are folks out there who actually look at htese postings. Your help is much appreciated.

            • 3. Re: Problem creating service jboss.system:Service=MainDeploy
              Sabrina Schurhaus Newbie

              This problem is happening to me randomly, with different services (JARDeployer, ServiceDeployer, MainDeployer), and I cannot find the answer.

              I already follow the "Java 2 SDK 1.4.2 Installation Notes for Linux" and the problem still happens.

              I simply copy the same java and jboss folders to another machine and all goes fine. It´s probably a distro problem... but what?

              [ServerInfo] Java version: 1.5.0_07,Sun Microsystems Inc.
              [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_07-b03,Sun Microsystems Inc.
              [ServerInfo] OS-System: Linux 2.6.16-1.2108_FC4,i386

              • 4. Re: Problem creating service jboss.system:Service=MainDeploy
                Peter Johnson Master

                Please post the console output. It is hard to solve the problem without the specific error messages.

                Also, indicate how you installed JBoss (via the installer.jar file or by unzipping the zip file).

                • 5. Re: Problem creating service jboss.system:Service=MainDeploy
                  Sabrina Schurhaus Newbie

                  I installed the JDK1.5 with the sun's self-extracting binary and the JBoss by unzipping the file.

                  I'm posting the last output I got, since every time it gives me a different, but similar, error.

                  =========================================================================
                  
                   JBoss Bootstrap Environment
                  
                   JBOSS_HOME: /usr/jboss
                  
                   JAVA: /usr/java/bin/java
                  
                   JAVA_OPTS: -server -Xms128m -Xmx128m -Dprogram.name=run.sh
                  
                   CLASSPATH: /usr/jboss/bin/run.jar:/usr/java/lib/tools.jar
                  
                  =========================================================================
                  
                  13:33:48,102 INFO [Server] Starting JBoss (MX MicroKernel)...
                  13:33:48,104 INFO [Server] Release ID: JBoss [Zion] 4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)
                  13:33:48,105 INFO [Server] Home Dir: /usr/jboss
                  13:33:48,105 INFO [Server] Home URL: file:/usr/jboss/
                  13:33:48,106 INFO [Server] Library URL: file:/usr/jboss/lib/
                  13:33:48,107 INFO [Server] Patch URL: null
                  13:33:48,108 INFO [Server] Server Name: minimal
                  13:33:48,108 INFO [Server] Server Home Dir: /usr/jboss/server/minimal
                  13:33:48,109 INFO [Server] Server Home URL: file:/usr/jboss/server/minimal/
                  13:33:48,109 INFO [Server] Server Data Dir: /usr/jboss/server/minimal/data
                  13:33:48,110 INFO [Server] Server Temp Dir: /usr/jboss/server/minimal/tmp
                  13:33:48,110 INFO [Server] Server Config URL: file:/usr/jboss/server/minimal/conf/
                  13:33:48,110 INFO [Server] Server Library URL: file:/usr/jboss/server/minimal/lib/
                  13:33:48,111 INFO [Server] Root Deployment Filename: jboss-service.xml
                  13:33:48,116 INFO [Server] Starting General Purpose Architecture (GPA)...
                  Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/mx/server/registry/BasicMBeanRegistry
                   at org.jboss.mx.server.registry.BasicMBeanRegistry.class$(BasicMBeanRegistry.java:126)
                   at org.jboss.mx.server.registry.BasicMBeanRegistry.<clinit>(BasicMBeanRegistry.java:126)
                   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
                   at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
                   at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
                   at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
                   at org.jboss.mx.server.MBeanServerImpl.createRegistry(MBeanServerImpl.java:1484)
                   at org.jboss.mx.server.MBeanServerImpl.<init>(MBeanServerImpl.java:187)
                   at org.jboss.mx.server.MBeanServerBuilderImpl.newMBeanServer(MBeanServerBuilderImpl.java:56)
                   at javax.management.MBeanServerFactory.newMBeanServer(MBeanServerFactory.java:316)
                   at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:219)
                   at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:369)
                   at org.jboss.system.server.ServerImpl.start(ServerImpl.java:315)
                   at org.jboss.Main.boot(Main.java:195)
                   at org.jboss.Main$1.run(Main.java:463)
                   at java.lang.Thread.run(Thread.java:595)
                  



                  • 6. Re: Problem creating service jboss.system:Service=MainDeploy
                    Sabrina Schurhaus Newbie

                    I forgot to say that the VM crashes sometimes too.
                    Here is the last report:

                    #
                    # An unexpected error has been detected by HotSpot Virtual Machine:
                    #
                    # SIGSEGV (0xb) at pc=0x086a933e, pid=11327, tid=3086771904
                    #
                    # Java VM: Java HotSpot(TM) Server VM (1.5.0_07-b03 mixed mode)
                    # Problematic frame:
                    # C 0x086a933e
                    #
                    
                    --------------- T H R E A D ---------------
                    
                    Current thread (0x08689b38): JavaThread [_thread_in_vm, id=11327]
                    
                    siginfo:si_signo=11, si_errno=0, si_code=1, si_addr=0x00000001
                    
                    Registers:
                    EAX=0x00000001, EBX=0x00b1d970, ECX=0xffc0b480, EDX=0xb0de2a58
                    ESP=0xbf9cf104, EBP=0xbf9cf128, ESI=0x086a9338, EDI=0xb0de294c
                    EIP=0x086a933e, CR2=0x00000001, EFLAGS=0x00010202
                    
                    Top of Stack: (sp=0xbf9cf104)
                    0xbf9cf104: 08689b38 00000411 00000411 b0de2a60
                    0xbf9cf114: b0de2910 b0de2a58 00b1d970 08689b38
                    0xbf9cf124: 086c58f8 bf9cf168 006945b6 086c58f8
                    0xbf9cf134: 08689b38 08689b38 086c58e0 08689cc0
                    0xbf9cf144: 0868a840 0868a848 0868ac34 00b10448
                    0xbf9cf154: bf9cf1cc bf9cf298 00b1d970 b0da21d8
                    0xbf9cf164: b0de2918 bf9cf298 00989750 086c58f8
                    0xbf9cf174: 086c58e0 08689b38 00000008 00000029
                    
                    Instructions: (pc=0x086a933e)
                    0x086a932e: 00 00 68 65 af 00 38 93 6a 08 28 64 af 00 04 00
                    0x086a933e: 00 00 01 00 00 00 00 00 d7 a8 00 00 00 03 00 20
                    
                    Stack: [0xbf7d3000,0xbf9d3000), sp=0xbf9cf104, free space=2032k
                    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
                    C 0x086a933e
                    V [libjvm.so+0x1265b6]
                    V [libjvm.so+0x41b750]
                    V [libjvm.so+0x41b366]
                    V [libjvm.so+0x241ab0]
                    V [libjvm.so+0x241936]
                    V [libjvm.so+0x41bb46]
                    V [libjvm.so+0x41b366]
                    V [libjvm.so+0x241ab0]
                    V [libjvm.so+0x241936]
                    V [libjvm.so+0x2412d9]
                    V [libjvm.so+0x41efae]
                    V [libjvm.so+0x25609c]
                    j java.lang.ThreadGroup.add(Ljava/lang/ThreadGroup;)V+28
                    j java.lang.ThreadGroup.<init>(Ljava/lang/ThreadGroup;Ljava/lang/String;)V+61
                    v ~StubRoutines::call_stub
                    V [libjvm.so+0x2649ac]
                    V [libjvm.so+0x427bc8]
                    V [libjvm.so+0x264442]
                    V [libjvm.so+0x2645b8]
                    V [libjvm.so+0x4cc199]
                    V [libjvm.so+0x4ca4b9]
                    V [libjvm.so+0x28e85c]
                    C [java+0x32cc]
                    C [java+0x15a4] calloc+0x39c
                    C [libc.so.6+0x14d7f] __libc_start_main+0xdf
                    
                    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
                    j java.lang.ThreadGroup.add(Ljava/lang/ThreadGroup;)V+28
                    j java.lang.ThreadGroup.<init>(Ljava/lang/ThreadGroup;Ljava/lang/String;)V+61
                    v ~StubRoutines::call_stub
                    
                    --------------- P R O C E S S ---------------
                    
                    Java Threads: ( => current thread )
                    =>0x08689b38 JavaThread [_thread_in_vm, id=11327]
                    
                    Other Threads:
                     0x08720b10 VMThread [id=11328]
                    
                    VM state:not at safepoint (normal execution)
                    
                    VM Mutex/Monitor currently owned by a thread: ([mutex/lock_event])
                    [0x086895e0/0x086895f8] MultiArray_lock - owner thread: 0x08689b38
                    [0x086897b0/0x086897c8] Compile_lock - owner thread: 0x08689b38
                    
                    Heap
                     def new generation total 13120K, used 234K [0xa8d70000, 0xa9ba0000, 0xa9ba0000)
                     eden space 11712K, 2% used [0xa8d70000, 0xa8daa908, 0xa98e0000)
                     from space 1408K, 0% used [0xa98e0000, 0xa98e0000, 0xa9a40000)
                     to space 1408K, 0% used [0xa9a40000, 0xa9a40000, 0xa9ba0000)
                     tenured generation total 116544K, used 0K [0xa9ba0000, 0xb0d70000, 0xb0d70000)
                     the space 116544K, 0% used [0xa9ba0000, 0xa9ba0000, 0xa9ba0200, 0xb0d70000)
                     compacting perm gen total 16384K, used 458K [0xb0d70000, 0xb1d70000, 0xb4d70000)
                     the space 16384K, 2% used [0xb0d70000, 0xb0de2ab0, 0xb0de2c00, 0xb1d70000)
                    No shared spaces configured.
                    
                    Dynamic libraries:
                    00111000-00117000 r-xp 00000000 03:01 1069754 /usr/jdk1.5.0_07/jre/lib/i386/native_threads/libhpi.so
                    00117000-00118000 rwxp 00006000 03:01 1069754 /usr/jdk1.5.0_07/jre/lib/i386/native_threads/libhpi.so
                    00118000-00121000 r-xp 00000000 03:01 2074676 /lib/libnss_files-2.3.6.so
                    00121000-00122000 r-xp 00008000 03:01 2074676 /lib/libnss_files-2.3.6.so
                    00122000-00123000 rwxp 00009000 03:01 2074676 /lib/libnss_files-2.3.6.so
                    00123000-0012e000 r-xp 00000000 03:01 1069766 /usr/jdk1.5.0_07/jre/lib/i386/libverify.so
                    0012e000-0012f000 rwxp 0000b000 03:01 1069766 /usr/jdk1.5.0_07/jre/lib/i386/libverify.so
                    0012f000-00150000 r-xp 00000000 03:01 1069767 /usr/jdk1.5.0_07/jre/lib/i386/libjava.so
                    00150000-00152000 rwxp 00020000 03:01 1069767 /usr/jdk1.5.0_07/jre/lib/i386/libjava.so
                    00152000-0019a000 rwxp 00152000 00:00 0
                    0019a000-001b2000 rwxp 0019a000 00:00 0
                    001b2000-001f5000 rwxp 001b2000 00:00 0
                    001f5000-0020d000 rwxp 001f5000 00:00 0
                    0027b000-00284000 rwxp 0027b000 00:00 0
                    00284000-0033b000 rwxp 00284000 00:00 0
                    0035a000-0035b000 r-xp 0035a000 00:00 0 [vdso]
                    0035b000-00375000 r-xp 00000000 03:01 2074626 /lib/ld-2.3.6.so
                    00375000-00376000 r-xp 00019000 03:01 2074626 /lib/ld-2.3.6.so
                    00376000-00377000 rwxp 0001a000 03:01 2074626 /lib/ld-2.3.6.so
                    00379000-0049c000 r-xp 00000000 03:01 2074634 /lib/libc-2.3.6.so
                    0049c000-0049e000 r-xp 00122000 03:01 2074634 /lib/libc-2.3.6.so
                    0049e000-004a0000 rwxp 00124000 03:01 2074634 /lib/libc-2.3.6.so
                    004a0000-004a2000 rwxp 004a0000 00:00 0
                    004a4000-004a6000 r-xp 00000000 03:01 2074642 /lib/libdl-2.3.6.so
                    004a6000-004a7000 r-xp 00001000 03:01 2074642 /lib/libdl-2.3.6.so
                    004a7000-004a8000 rwxp 00002000 03:01 2074642 /lib/libdl-2.3.6.so
                    004aa000-004cd000 r-xp 00000000 03:01 2074636 /lib/libm-2.3.6.so
                    004cd000-004ce000 r-xp 00022000 03:01 2074636 /lib/libm-2.3.6.so
                    004ce000-004cf000 rwxp 00023000 03:01 2074636 /lib/libm-2.3.6.so
                    004e6000-004f4000 r-xp 00000000 03:01 2074644 /lib/libpthread-2.3.6.so
                    004f4000-004f5000 r-xp 0000d000 03:01 2074644 /lib/libpthread-2.3.6.so
                    004f5000-004f6000 rwxp 0000e000 03:01 2074644 /lib/libpthread-2.3.6.so
                    004f6000-004f8000 rwxp 004f6000 00:00 0
                    0056e000-00abf000 r-xp 00000000 03:01 1069756 /usr/jdk1.5.0_07/jre/lib/i386/server/libjvm.so
                    00abf000-00b21000 rwxp 00551000 03:01 1069756 /usr/jdk1.5.0_07/jre/lib/i386/server/libjvm.so
                    00b21000-00f39000 rwxp 00b21000 00:00 0
                    00f39000-00f3a000 --xp 00f39000 00:00 0
                    00f3a000-00fba000 rwxp 00f3a000 00:00 0
                    00fc0000-00fd3000 r-xp 00000000 03:01 1069769 /usr/jdk1.5.0_07/jre/lib/i386/libzip.so
                    00fd3000-00fd5000 rwxp 00012000 03:01 1069769 /usr/jdk1.5.0_07/jre/lib/i386/libzip.so
                    03d15000-03d26000 r-xp 00000000 03:01 2074649 /lib/libnsl-2.3.6.so
                    03d26000-03d27000 r-xp 00010000 03:01 2074649 /lib/libnsl-2.3.6.so
                    03d27000-03d28000 rwxp 00011000 03:01 2074649 /lib/libnsl-2.3.6.so
                    03d28000-03d2a000 rwxp 03d28000 00:00 0
                    03d2a000-03f6a000 rwxp 03d2a000 00:00 0
                    03f6a000-06d2a000 rwxp 03f6a000 00:00 0
                    08048000-08057000 r-xp 00000000 03:01 1070406 /usr/jdk1.5.0_07/bin/java
                    08057000-08059000 rwxp 0000e000 03:01 1070406 /usr/jdk1.5.0_07/bin/java
                    08686000-0872e000 rwxp 08686000 00:00 0 [heap]
                    a8d70000-b1d70000 rwxp a8d70000 00:00 0
                    b1d70000-b4d70000 rwxp b1d70000 00:00 0
                    b4d79000-b55e6000 r--s 00000000 03:01 1070378 /usr/jdk1.5.0_07/jre/lib/charsets.jar
                    b55e6000-b55fb000 r--s 00000000 03:01 1069810 /usr/jdk1.5.0_07/jre/lib/jce.jar
                    b55fb000-b5680000 r--s 00000000 03:01 1070321 /usr/jdk1.5.0_07/jre/lib/jsse.jar
                    b5680000-b56e9000 rw-p b5680000 00:00 0
                    b56e9000-b7ced000 r--s 00000000 03:01 1070400 /usr/jdk1.5.0_07/jre/lib/rt.jar
                    b7ced000-b7de4000 r--s 00000000 03:01 519559 /usr/jboss/lib/endorsed/xercesImpl.jar
                    b7de4000-b7e03000 r--s 00000000 03:01 519560 /usr/jboss/lib/endorsed/xml-apis.jar
                    b7e03000-b7e12000 r--s 00000000 03:01 519557 /usr/jboss/lib/endorsed/resolver.jar
                    b7e12000-b7fc6000 r--s 00000000 03:01 519558 /usr/jboss/lib/endorsed/xalan.jar
                    b7fc6000-b7fc8000 rw-p b7fc6000 00:00 0
                    b7fca000-b7fd2000 rw-s 00000000 03:01 1199408 /tmp/hsperfdata_root/11327
                    b7fd2000-b7fd3000 rw-p b7fd2000 00:00 0
                    b7fd3000-b7fd4000 r--p b7fd3000 00:00 0
                    bf7d3000-bf7d6000 ---p bf7d3000 00:00 0
                    bf7d6000-bf9d3000 rw-p bf7d6000 00:00 0 [stack]
                    
                    VM Arguments:
                    jvm_args: -Xms128m -Xmx128m -Dprogram.name=run.sh -Djava.endorsed.dirs=/usr/jboss/lib/endorsed
                    java_command: org.jboss.Main -c minimal
                    Launcher Type: SUN_STANDARD
                    
                    Environment Variables:
                    JAVA_HOME=/usr/java
                    PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/java/bin:/root/bin
                    LD_LIBRARY_PATH=/usr/jdk1.5.0_07/jre/lib/i386/server:/usr/jdk1.5.0_07/jre/lib/i386:/usr/jdk1.5.0_07/jre/../lib/i386
                    SHELL=/bin/bash
                    
                    Signal Handlers:
                    SIGSEGV: [libjvm.so+0x5016a0], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
                    SIGBUS: [libjvm.so+0x5016a0], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
                    SIGFPE: [libjvm.so+0x426c00], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
                    SIGPIPE: [libjvm.so+0x426c00], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
                    SIGILL: [libjvm.so+0x426c00], sa_mask[0]=0x7ffbfeff, sa_flags=0x10000004
                    SIGUSR1: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
                    SIGUSR2: [libjvm.so+0x429050], sa_mask[0]=0x00000000, sa_flags=0x10000004
                    SIGHUP: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
                    SIGINT: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
                    SIGQUIT: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
                    SIGTERM: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
                    
                    
                    --------------- S Y S T E M ---------------
                    
                    OS:#redhat-4
                    Fedora Core release 4 (Stentz)
                    
                    uname:Linux 2.6.16-1.2108_FC4 #1 Thu May 4 23:52:01 EDT 2006 i686
                    libc:glibc 2.3.6 NPTL 2.3.6
                    rlimit: STACK 10240k, CORE 0k, NPROC 16383, NOFILE 1024, AS infinity
                    load average:0.29 0.10 0.02
                    
                    CPU:total 1 family 6, cmov, cx8, fxsr, mmx, sse
                    
                    Memory: 4k page, physical 1035756k(52036k free), swap 2229736k(2228220k free)
                    
                    vm_info: Java HotSpot(TM) Server VM (1.5.0_07-b03) for linux-x86, built on May 3 2006 00:32:58 by java_re with gcc 3.2.1-7a (J2SE release)
                    
                    


                    • 7. Re: Problem creating service jboss.system:Service=MainDeploy
                      Peter Johnson Master

                      The missing class (BasicMBeanRegistry) is found in the ./lib/jboss-jmx.jar file. Have you checked the access controls on the files in that directory? On my system, my user account owns all of the files and has full rights (755).

                      However, the fact that you are getting JVM dumps leads me to believe that there is something else fundamentally wrong in your system. I ran JBoss of JC4 for a year with no problems. I am now on FC5 and JBoss still runs fine (I'm using JDK 1.4.2_11 and 1.5.0_06). Do you have another machine onto which you could wipe clean and install FC4, the JVM and JBoss?

                      Are you running SELinux? Have you made any special settings changes in SELinux? If so, could you try turning SELinux off and see if that resolves the problems (90% of the time I can't figure out why something is not working that should, it ends up being an SELinux configuration issue).

                      • 8. Re: Problem creating service jboss.system:Service=MainDeploy
                        Sabrina Schurhaus Newbie

                        Things are still unstable.

                        I'm testing everything as root, so it's cannot be access control.

                        Unfortunally I have to put this to work in this machine, without loose anything.
                        I tested the same files in a machine with Ubuntu and all works fine.

                        SELinux is disabled.

                        I updated the entire system (yum update) and now another message appears sometimes "*** glibc detected *** double free or corruption". This appears to be a GREAT problem. But I'm still confused if it is something in the Sun JDK 1.5.0_07 or in my system libraries.

                        I reported the problem to Sun too.