2 Replies Latest reply on Jul 22, 2006 6:20 PM by Peter Johnson

    Could not start JBoss 4.0.4

    Anand Kulkarni Newbie

      Hi,

      I downloaded JBoss4.0.4 as jboss-4.0.4.GA.zip file.
      I extracted it on c:\ Now I want to start JBoss, hence I set JAVA_HOME env and run the run.bat file from C:\jboss-4.0.4.GA\bin

      When I run the run.bat file, it gives me lots of errors. Mainly gives me 2 errors
      1) comp not found
      2) Port 8080 is already in use

      I could start JBoss3.0.8 vesion but JBoss4.0.4 is giving me errors.

      Can somebody tell me how to start JBoss4.0.4?

      regards,

      Anand

        • 1. Re: Could not start JBoss 4.0.4
          srinivas k Newbie

          Could not start JBoss--------------
          Instead of creating a new configuration under 3.2.x, i tried creating one under an already existing configuration.....also i didnot include any source and tried starting the server in debug mode when i was echoed that source level was not found.....later i could not delete this currently created configuration nor could i include source and im getting repeated error pop-up's.....wht shud i do

          • 2. Re: Could not start JBoss 4.0.4
            Peter Johnson Master

            srinivas.k, you should have started a new topic rather than posting on an existing topic. But since Anand posted the same question to multiple forums (also frowned on), and his question is being answered in another post, I will try to help.

            But first, your question isn't clear and doesn't provide enough information to help you with your problem. You say you are using JBoss 3.2.x. Which version, exactly? 3.2.7?

            You said you did not create a new configuration but then said "I tried creating one". Was that a typo, in other words, did you mean "I tried starting one"? If not, what did you mean by "creating one"? Your statement is especially confusing since later you say "I could not delete this currently created configuration". So, did you or did you not create a new configuration?

            What do you mean by not including any source code? Are you saying that you did not deploy any of you own applications to JBoss?

            How did you start the server in debug mode? Do you mean that you ran via an IDE such as Eclipse?

            You said you are getting error pop ups. Once again this implies to me that you are starting the server via and IDE. What do the pop-ups say. Without the exact text it is impossible to help.

            Try this. From a command prompt, go to the bin directory where JBoss is installed and run the run.bat or run.sh file. Once you see the "server started in xxx seconds" messages, you should be able to one a browser and enter the URL http://localhost:8080 and see the JBoss welcome page. If this works, then JBoss is running fine. If it doesn't, post the text that was output to the command window.